Steinberg Download Assistant not running

Hi all,

I’m trying to run the Steinberg Download Assistant 1.14.7 under Mac OS 10.13.6 to download Dorico Elements 2, which I’ve just bought online. However, when I run it, I briefly get a load message “Launching the Steinberg Download Assistant” and then it appears to quit without doing anything.

I’ve tried rebooting and running the installer directly after the reboot, but that makes no difference.

Can anyone suggest what I can do to download Dorico Elements 2 directly?

Best regards,


Sorry to hear of this problem, James. Normally when SDA doesn’t run it’s because of some problems with fonts on your system. Can you try running Font Book and checking for any problems with unresolved duplicate fonts, etc., and resolving those problems?

In the meantime, you can download Dorico 2.2 from the following direct links:

Application installer

HALion Sonic SE 3

So, I resolved the four duplicate fonts in Font Book automatically, then rebooted. No improvement with the SDA, even after a reinstall of the SDA.

I’m using the direct links now, which look okay.