Steinberg Hub Not loading News and Tutorials

I have cubase 8.5 up to 10. The Hub loads but none of them are showing the news and tutorials. Tried trashing preferences but no joy. Im using iMac and Mojave OS


This is already discussed here on the forum. So far it’s not really clear the cause of it. It’s definitely macOS only (I can reproduce it even on macOS 10.13). Once this happens, all Cubase versions installed are affected. It seems to be not linked with the eLCC version. So far a mystery for me.

Its very strange-Ive tired everything including Security & Privacy and Accessibility Panels. Ive also made sure my eLicence is up to date.

This has started happening to me since installing Cubase 10.0.15, prior to that it worked fine. Using the latest eLicenser and Mojave 10.14.3.


Do you have an older Cubase installed? Can you see the same in the older Cubase version? I can reproduce it with any Cubase version now.

Yes I have other versions installed back to 8.5 but its sill the same. I did get in ouch with Steinberg and they’ve said
“We are aware of the situation, this may be a bug in the software. If the bug is confirmed, an update on the eLicenser Control Center should fix it”

This also has started happening to me since installing Cubase 10.0.15, prior to that it worked great. Using the latest eLicenser and Mojave 10.14.3. on my Mac Mini 2018 model 3.2GHz Intel Core i7 with 16GB 2667 MHz DDR4 memory on a solid high speed WiFi network, so I don’t believe it’s a hardware issue. Hope it gets some corporate attention because this feature was a lot more than eye candy to me. Great forum, and good to know I’m not alone with the the joys, and an occasional hiccup using the worlds greatest DAW bundle.

I have Cubase Pro 10.0.10 and the News have not been loading in the hub for several days now. I understand there is an update to 10, how can I access it other than through the Hub?

I just amazed at the lack of speed sorting this problem

Same issue with CUBASE LE AI Elements 9 for a few days now.

The Hub will tell you there is no connection but won’t detect when a connection is (re)established, you have to close Cubase 10 and open it again. Lacklustre UX right there.

Still not loading for me, any time at all. Updated to 10.0.15 by going online through a web browser.

Just launched Cubase and news & tutorials has appeared:-) Was not working yesterday. Thanks to Steinberg for hopefully fixing this.

Yes!! same for me! Cubase 10

I have this problem on Windows 10, on Cubase Pro 10.0.15, starting today (10.0.15 has worked fine until today). Martin in an earlier post said “It’s definitely macOS only” - well not in my case.

Same problem here, Win 10’ Cu 10.0.15 Built 136’
Cu works perfectly except error msg “no internet connection detected” in the hub.
Prob started on, or shortly before April 7th.

I have the same problem started today around 5pm

I am having this problem just started. I have updated elicenser and same issue is occurring still. I am on a Win 10 OS. It is doing this in every version of Cubase 9, 9.5, 10. Nothing has been changed or installed on my system. Last time I had this problem was 3 years ago and it was a plugin blocking the internet via firewall… Needless to say my system has been running flawless since getting rid of that old plugin 3 years ago… UNTIL today, when it decides to not work correctly anymore.

Same here. Cubase 10.0.15 and Win 10.

Same here on Windows 7!