Steinberg Hub should not force Edge on Windows

I have Edge still installed on Windows but have only ever used it to download Firefox, which is set as my default browser.

When I click on an item in the Steinberg Hub, it opens Edge. Cubase should instead respect the user’s preference of default browser.

Please vote for this feature request.


Not only that, but it opens minus the tabs, toolbars, menus, etc. Naughty, Steinberg.

Not OK Steinberg.

1 Like

It is a security issue. It should not open any browser without consent.
And when open it should be done with full control from the user.
Eg have possibility to have a private instance of the browser or a private instance within or what ever.

Maybe it something for GDPR people to take Yamaha by the ear.
Yamaha have as turnover of 3.38 billion dollars. GDRP is 2% or
60 million dollars. I think ROI on the fix might be a low hanging fruit.


I think the consent issue could be dealt with by first informing users that clicking on an item in the hub would open an external website in a browser. Now that the hub is the central to the application in both Cubase 13 and WaveLab 12, I think there should be a configurable option to not send HTTP requests to external websites every time the application is started.

Well at least it doesn’t open Internet Explorer …

Cubase 13 pro opens Chrome on my PC.

You are the exception that proves the rule!

Just at work on my laptop which is running Win 11 and Cubase pro 12.

The HUB links opens a browser within Cubase called WebView. (Check on Task Manager)

Opening Help from within Cubase Main Menu opens Chrome.


I’m on Windows 10 and Firefox is my default browser, yet I get this when I click on an item in the hub.

WebView is an embedded browser, and uses the Edge rendering engine but it runs in Cubase’s memory space. If you have Show News in Hub deactivated, WebView doesn’t even launch. It is not running as an instance of the Edge browser,

and has a different user directory as well, located in %AppData%\Steinberg\

see What is webview edge


UAD plugins also use edgeview. It’s aggravating.

One advantage is that it doesn’t break if the default browser can’t be launched. Another is that any tracking is limited to Webview, and not your default browser.

It’s also simple to drag the link to a browser window.

I can’t actually see how this is bad.

This isn’t a Steinberg issue, this is a Windows architecture issue. Microsoft is pushing a new web-view standard and the developers are following MS’s “best standards” for developing and presenting web content from within a native application, regardless of how annoying this new process is as an end-user.


OK I found this setting now and deactivated it. In previous versions, I’d always had the hub itself deactivated, but now that it’s effectively the entry point to the application in Cubase 13, I didn’t realise I could just deactivate the “news” section. I don’t think that option exists for WaveLab 12 though, which has a more useful “hub”.

I’ll mark this as the solution, but am still grumbling!

Yes, Microsoft Edge Webview. I guess that’s OK then. (… looks for the “sarcasm” emoji …) :smiling_imp:

1 Like

Hi everyone,

Thanks for your report @MrSoundman . The relevant persons were informed of this issue / feature request.



Where do you deactivate it?

Preferences->General->Show News in Hub.


See Issue - Cubase 12 launch Windows Edge, not the selected default browser - #2 by Phillipus

1 Like

Thank you @Phillipus! This works perfectly in Cubase 13.

(rename %PROGRAMFILES%\Steinberg\Cubase 13\Components\WebView2Loader.dll)
Apologies Steve, I’ve revoked your “solution” and reallocated it to Phillipus :slight_smile:

I’m hurt. :sob:

It’s a workaround till you do an update or reinstall. I also remove several components that I don’t use, but doing this type of thing is for ‘advanced’ users.