Steinberg Mastering Edition Cannot Install on Windows 7 64bi

Hi,

I have this installed on a Windows 7 Ultimate 32bit PC and it works fine

It will not install on Windows 7 Ultimate 64bit. Installer says needs a 64bit version

Is there a 64bit version or a work around?

Thanks in advance

Hi PG,

Can you expalin why the ME Edition cannot work with Windows 7 64bit PC

I installed the Mastering Edition 1.0 version on Windows Virtual Machine (XP mode) on Windows 7 64bit PC. I then copied all 5 Plugin dll files into plugin directory for WL8 and was able to get 3 working (Loudness Maximizer was one that worked. Freefilter and Compressor did not work ) I cannot remember all since I did this on Friday and I’m writting this from work and I do not have WL8 on my work PC to confirm the others. But I could not do this with the update v1.5 Mastering edition which I want to do especially for the Loudness Maximizer Plugin which is one of my favorites. I know people will say their are other compatible ones I can use. I have the Waves Ultramaximizer+ and a few other Waves Maximizers along with the built in WL8 Maximixer which are nice but I like the ME Loudness Maximizer best for whatever reason. I’m used to using it and would like to continue. I was able to get the 1.0 version to work but not the 1.5

I paid for this and can’t remember how much but it wasn’t cheap and I’m dissapointed that it seems no update from you guys was issued and with a little creative think on my part got half of them to work. If it’s not compatible thats one thing but just copying the plugins to correct directory gets half of them to work is just plain not cool leading people to think it’s not compatible. Not compatible to me means it will never work and the software would have to be totally rewritten but is seems to me only the ME setup.exe fails in Windows 7 saying you need a 64bit version, but I just copied the Plugin dll to the correct WL directory.

Sorry for the rant, but I really like the ME plugins compared to the the compatible WL8 Legacy plugins. So please tell me why an update was never issued. I hate spending money again on stuff I already own and I suspect most people feel the same way.

Thanks,
Scott

Hi PG,

How about this one. Dissapointed I can’t use this.

Thanks,
Scott

I don’t have the ME Edition, I can’t say anything. Try with WaveLab 8.0.2 when available.

Hi PG,

The problem with the (ME) mastering edition is the setup.exe on both CDs (v1.0 & v1.5) will not install on Windows 7 64bit…It returns an error looking for a 64bit version.

I worked around this by installing Windows Virtual Machine (XP mode) on my Windows 7 64bit PC and then installing the the Mastering Edition 1.0 version on it. I then copied all 5 Plugin dll files from the folder it was in on the virtual PC into the plugin directory for WL8 and was able to get a couple working (Loudness Maximizer & Compressor) but the others did not. I did the same process for the ME v1.5 but none of them worked at all so right now I have the 2 listed above working (v1.0) but not the latest version of each (v1.5)

So WL 8.0.2 update will not make a difference since I can’t get past the initial ME installer on Windows 7 64bit PC…Unless the WL 8.0.2 version will now recognize the ME v1.5 using my method of installing the Plugins on virtual PC and then just copying plugins to correct WL8 folder

Later today or tomorrow I will try installing ME v1.0 and then update to v1.5 on Windows 7 32bit PC and see what happens. If successful I will test to see if WL 8 can recognize them.

Thanks,
Scott

Scott, I am very sorry but the Mastering Edition has long been discontinued and if I recall it correctly, the last supported OS was Windows XP in a 32-bit environment. The company that made those plug-ins does not exist anymore and there is no way we can provide an update that makes these plug-ins work on a contemporary OS.

Hello Scott,
a hint that might help.
I had an application (XGWorks from Yamaha) that had a similar errormessage.
I installed the software on Windows XP and took the whole installation directory from XP and placed it on Windows 7 64-Bit in the Programm Files (X86) folder. I started the software then (placed an Icon on the Desktop) and since then it is working without any problem.
I cannot guarantee that this works for your Software too, but you can give it a try.

All the best
Franz

Hi Ed…Thanks for letting me know


Hi Frank I kinda did that and was only able to get 3 plugins working (only the ME 1.0 version). I tried the same thing with the ME 1.5 version and WL 8 returns and error when trying to load them

This issue for me is only with Windows 7 64bit. I have the ME 1.5 version installed on Windows 7 32bit PC and WL7/8 opens them with no problem

Atleast the plugins that I like I was able to get working
Scott

hi scott
i’m using the mastering edition 1.5 without any problems.
all plugs, Compressor, Freefilter, Loudnessmaximizer, PhaseScope, Spectralizer, SpectorGraph…they all run flawlessly.
windows 7, x64 / wavelab 7, now 8. wavelab installed as the 32bit version.
do you have wavelab 8, 32 bit installed?

Hi,

Yes, It’s WL8 32 bit installed on Windows 7 Ultimate 64bit

How were you able to install me 1.5

Been trying everything with only mixed results

Thanks,
Scott

well, i don’t know. over a long period i had to do several windows 7,64 installations due to viruses or a damaged windows (recently i did a complete new windows & wl install in order to get the q-metric plugin running - with no success). but i never had any problems with the me plugins.
might be that some other program installed on your pc or a driver interferes with the directx component?
try a complete clean install of windows, all needed drivers and updates, no other programs and then wavelab and the me 1.5 plugs.
ah, and try not installing the me 1.5 plugs as wavelab-plugins, just as vst-plugs…
good luck

I just did a clean install of Windows 7 64bit. The ME does not get past the initial setup after inserting the CD. Are you installing the ME from a CD or is it a downloaded file
ME 1.5 Setup Error.gif
This is the error message I get. Looking more closely it says “this version of the file is not compatible with the version of Windows your running. See if you need 32 or 64 bit version”…What gives here Windows 7 64 bit should be able to install both 32 and 64bit programs.

neither from cd nor a downloaded file. years ago i backupped all my program-cds on hdd, so i still can install some precious dinosauers though i lost many cds during a move. so it seems i was lucky keeping a working me backup.
but unfortunately with q-metric same thing happened to me.
maybe you should google for me 1.5?

…hmm, why not try copying my way? copy the files on harddisc, then check out the attributs, change locked to unlock or hidden to unhidden. might be that windows wants to have access to some files for renewing…maybe windows would alter the installer file? this can’t be done if it’s a file on cd…

Hi

I will try that and see what happens…Copy to HD and change attributes

Thanks,
Scott

Hi,

Just tried changing attributes - both hidden and read-only were unchecked and I have full control and same error message so I may have to google it or if you want to PM me

let me know

Thanks,
Scott

Hi PG

Just installed 8.0.2 same as before WL does not see the 1.5 version of Mastering Edition (ME). Upon plugin detection before WL8 opens says “plugin not installed please reinstall” For the 1.0 version it works fine on 3 plugins (Compressor, Loudness Maximizer & Phasescope)

I would like to know why an older version 1.0 of ME works and the newer one 1.5 does not? I know it’s old but so are all of my "Wave"s plugins and they all work fine. Is their any work around? If anybody, you would be the one to get this to work.

Was hoping 8.0.2 would be kinder to legacy plugins but I guess not

Thanks,
Scott

Upon plugin detection before WL8 opens says “plugin not installed please reinstall”

This is not a WaveLab message. This must be a plugin message, when WaveLab tries to load the plugin.
The plugin is not installed properly under this system. Since you can’t run the installer under your system, something must be missing, unfortunatly.

Hi PG,

That messsage appears after you check “force detection at next launch” So Wavelab checks for plugins and on mine it says Plugin not installed please install again on all the ME 1.5 ones. You click “OK” and it continues to check the rest of the plugins until finished and then WL opens…Seems to me this is a Wavelab message
Plugin Loading Error.gif
You say the ME installer doesn’t work on my system so something is missing from my system…I tried both ME 1.0 and 1.5 disks at work on a few Window 7 64bit machines and got same message as I got on the one in question now That it cannot install.

Are you saying the ME 1.0 &1.5 installer should work on a Windows 7 64bit PC? but it doesn’t work on mine because something is misssing?

Please clarify this?

Thanks,
Scott

I confirm that this message:
2013-07-05_08-20-57.png
is not from WaveLab, hence it is from the plugin.

Are you saying the ME 1.0 &1.5 installer should work on a Windows 7 64bit PC

I don’t say this. On the contrary. As noted on one of your pictures:
2013-07-05_08-23-07.png
the ME installer is 12 years old. It’s not difficult to imagine compatibility issues with Windows 7 64 bit.
BTW, did you try running the ME installer in “compatibility mode” of an earlier Windows version?

Hi PG,

Yes, I tried every combination

So if the installer doesn’t work is their a manual way to install the plugins?

My method was that I manually copied the 1.0 ME plugins into the legacy folder in WL8 and 3 plugins worked not so for any of the 1.5. Do the plugins need to be registered with the OS or DirectX which the installer does?

I also was able to extract the plugins from the setup.exe on both ME Cds but that did not make a difference the 3 plugins from 1.0 worked and all from 1.5 did not

Thanks,
Scott