Steinberg UR22 - high background noise

Hallo everybody,
First of all I’d like to sorry for my English
I have a problem, and hopefully you could help me. Based on some positive reviews, I’ve purchased audio-interface Steinberg UR22 together with Cubase AI7 software.
I need it to record my acoustic guitar. So, I’ve noticed one big problem with this instrument. I am playing “fingerstyle” guitar (no strumming). That does mean that the input signal from my guitar is not so loud (just normal acoustic guitar sound). The problem is that I can not separate background noise produced by hardware and recorded by Cubase from the input signal which comes from the guitar. I have strong and permanent background noise, which makes me crazy. Since two weeks (every day), I try to fix that problem by adjusting input signals via hardware and software (Gain, EQ, etc). Unfortunately, northing helped me to reduce the noise without affecting the “signal of interest”.
Before this audio-interface goes into the garbage, I’d like to use a last chance and kindly ask you if you have any idea what could I do. Btw, I found in Internet several reviews pointing the same problem with the high noise-level.
Thank you very much in advance.
Alex_2

Assuming this is indeed noise generated by the interface and not physical background noise we’re talking about here.
Have you updated the YUSB driver? http://www.steinberg.net/forums/viewtopic.php?f=157&t=49458
If it’s hum we’re refering to, have you seen this post? http://www.steinberg.net/forums/viewtopic.php?f=157&t=39475

Thank you for the answering!
Regarding the first link, - yes, I have updated the driver for Windows Vista.
Concerning the second link – If I understand correctly, there are some problems with phantom power of devices with certain serial numbers.
Well, I still did not use phantom power and my device has another serial number as listed in a table of affected devices which I saw somewhere on the Steinberg web-site.

Have you tried using a different mic? I must assume you’re using dynamic mics, as you mention not using the phantom power (unless your mic has it integreated of course), perhaps you’re needing to turn the gain too high. Have you engaged the HPF.

I am sorry for misunderstanding.
I am not using a microphone at all. So far, I do not have microphone to test it.
My acoustic guitar was plugged directly to the device (no mic). I have tried different settings (with and without Hi-Z). The background noise was relatively high as compared with the sound of guitar in either case. I have to say that recorded sound of the guitar was awesome (very nice, clear and brilliant). However, the hum noise is annoying. If I’m playing the guitar relatively loud (f.ex. strumming) then, in principle, I can ignore background noise. However, when I am playing not so loud (f.ex. finger-style or classical music) then the noise is really evident and irritating. Moreover, if I disconnect my guitar from the device, I still hear that noise indicating that the noise is coming from the device.
Anyway, Steinberg UR22 now goes back to the music store.
P.S. By the way, in Internet I found some more opinions from other peoples saying that this device is not really suitable for recording of plugged acoustic guitar.

Hi Alex 2. … I sympathise with you. And four years later, I have the same problem with recording a very expensive Lowrey organ (AUX OUT) to the UR22. The background noises are so bad that I feel this unit it totally useless. After three weeks searching the internet, I haven’t found anything from Steinberg to help correct this situation. I have tried all possible connections to no avail. Also ALL unit settings. Also using Reaper which shows the same problems as Cubase.
This unit is going to be returned pronto. Like you Alex, I have tried and wanted it to work, but it DON’T!
Best regards and hopefulness to all who wasted their money on this equipment.