Steinberg ur22 - mono/stereo problem

Hi guys :slight_smile:

I have a problem with recording and playing with Steinberg ur22. I have a mono signal while I’m playing/recording live from my synthesizer and there’s no difference what possition I set the “mix” potentiometer (input or daw) - on both there is mono, only volume level changes (input - loud, daw - silent). Stereo signal is only when I play recorded music. More strange is when I plug out one of the channel wire - I still hear mono on both speakers. At the beginning I thought there’s a hardware problem, but it wasn’t. I tried different combinations of plugging wires - through mixer or directly from synthesizer to Steinberg, I tried reinstall Steinberg and also updated the latest Steinberg driver from Steinberg website - but it didn’t help too :frowning: The synthesizer or mixer settings haven’t been changed.
A few days ago, I found here a post where someone had a similar problem and someone else answered that recording in mono is a normal thing. I could agree with that if I had for example the bass guitar, but the “mono problem” has appeared since I installed Windows 10 (legal version) system on my PC. On previous Windows 7 system everything was ok. When I turned a potentiometer to “daw” possition during recording, I had still heard the same stereo like after recording - the signal was only a little bit delayed with a few miliseconds. On “input” possition nothing was delayed and the sound was more like mono, but I know that’s just a latency thing. I also tried to change the number of samples in latency but that didn’t help - still nothing changed.
Recording in mono is annoying and disturbing to me, and I feel discouraged with further composing of my music.

Please help me where is the problem and what should I do? Is it the Windows system problem or Steinberg UR22 is too new device and doesn’t have the right driver for Windows 10 yet? If so, maybe I should get back to Windows 7? :slight_smile: Or maybe there are any hidden options in Windows 10? Maybe someone had the similar problem?