Steinberg UR22 not getting audio back from the computer

Okay, so still learning Linux, looked up some of the previous conversations I was able to find related to my issue.

Just bought a Steinberg UR22 USB interface, and working on getting it all working. The system recognizes the device, I think I have it set up correctly on Qjackctl, though all the tutorials seem to have a different interface that has all the setup audio on one screen, mine has a number of things on an ‘advanced’ tab, but I set it up as shown, interface set to the ur22, adjusted for latency. The connections look normal on jack, as compared to guides I’ve seen online.

Tried various software, Ardour, Rakkarack, Guitarix, none get a signal and none send one back to the interface, the only signal through headphones plugged into the interface is from the interface.

Audacity gets a signal, but doesn’t seem to send one back to the interface.

Not sure where to go with it next, I’m on Ubuntu Studio 18.04.4 LTR.

Saw the thread below, tried it, but no change:

I have seen mention somewhere that user permissions for some things on jack may be needed for some things, but haven’t been able to find where I saw that.

Anyway, thanks for any help!


Okay, now I have upgraded to 20.04, saw mention that doing that helped others, no difference.

One thing I did notice, before I upgraded to 20.04, I checked audacity, which was getting audio from my guitar where other things weren’t, I looked in preferences in audacity, and under the device tab if the host was ALSA it would get the signal, but if I changed the source to Jack, it would get nothing.

Post upgrade, Audacity doesn’t seem to want to record when I set the host to ALSA, and records when I have it set to Jack, but it isn’t actually getting any signal when set to Jack, so it’s just silence.

Not sure what my next step is.

Whichever software you are using, there will be settings for audio, and also for inputs and outputs. Unfortunately I don’t run any of the software you mention, so no real help maybe, but I think this will solve your problems once you locate those settings in the recording software.
Maybe you will also need to set up the audio in Linux, but I suck at that too, sorry.

Thanks, Strummer.Trying to figure that out at the moment.

What I know now: the ur22 is actually getting signal from the computer, like if I play a Hydrogen drum loop I can hear it through the UR22, so that functions.

Trying to trace through and figure out settings, I’m learning as I’m going on this one.

Good, then the system settings seem to work properly, look into the routing settings in your DAW and you should be fine:)