Stem Directions - Inconsistencies

I have stem settings where the default middle line stem direction is down, and stems are always down on the middle line. However, when I have chords (i.e. A and C in treble clef), the stems are sometimes up. Is there a way to change this globally? Is there a reason why telling Dorico to ignore the context of the notes around it for stems on individual notes doesn’t apply to chords?



Yes, this is because Dorico considers the stem direction of notes on the middle line of the staff – and by extension the stem directions for beamed groups where all of the notes are either on the middle line of the staff or are equally balanced either side of the middle line of the staff – to be contextual, i.e. to be determined by the surrounding musical context. If you want to disable this, you’ll find the relevant options under the Stem Directions heading in the Stems section of the Notes page of Engrave > Engraving Options.

Thanks for the reply, Daniel. I have that disabled but it still happens in some spots for chords…not for individual notes on the middle line though.

If you have any specific examples you’d like me to take a look at, please stick them in a minimal project and attach them here. I’d be happy to investigate further for you.

Thanks! It won’t let me attach the Dorico file, but here’s a screenshot as an example, and another that shows the stem direction settings. You can see the B on beat 4 has a down stem, but the A-C on beat 1 is stem up. As far as I can tell I have the settings set up so that the stems should be down, but maybe I’m missing something somewhere. Or maybe this is just a bug that has been fixed in the newer releases? I’m still on

Thanks again!

Jeremy, to post a Dorico file, either zip it up first, or simply add “.zip” to the extension to fool the forum.

Ah…clever. Here it is.

JAW (311 KB)

Dorico’s doing what I would expect here: you have specified that it should not take the stems of surrounding notes into consideration when determining stem directions, and set the default stem direction to down. The first chord on A and C has equal stem weight up and down, so it goes down because that’s what you’ve specified; likewise, the final B has equal stem weight up and down, so it goes down; the eighth notes in between are stem up because the B has equal stem weight up and down, but the A dictates that the stem should go up.

That’s bizarre. The first stem is up when I open the file (you can see in the jpg I posted earlier). Maybe a glitch in the older version?

I guess that’s possible, yes. I forgot you were using Dorico 1.2.10, sorry about that.

No worries. I’ll be upgrading soon. Just glad to know I’m not crazy. :wink: