Stem issue within two voices


There is one problem that I am hoping you can help me fix. When I allow two voices to overlap, and one of them has an open notehead, the end of the stem is visible. Is there any point in the json where I should tweak this? Or any parameter in Dorico to tweak too?

Thanks a lot for you help.

Hi Nor. I don’t think this is default behavior. Looks like the attachment points in the notehead editor have been moved…

1 Like

Marc, actually a customer of my NF reported the issue I posted above, and that what I guessed too.

@Chase43078 please see what Marc wrote above :wink: I think you’ll need to tweak the stem point attachment in Dorico 4: Library / Notehead Set… / Default Noteheads.

I suspect the problem is something else: In the above illustration the half-notehead is a bit wider than the black notehead, which is not the case in Bravura. Daniel has expressed doubt about this (although one can point to published examples, most notably the highly compacted Schott engravings of Wagner’s Ring).

The result with this font is that Dorico’s normally seamless overlapping of the different noteheads requires a slight adjustment in Engrave mode.

1 Like

@Mark_Johnson Thanks for your reply, but see below, the same font used by @Chase43078 is looking fine here with NO adjustments!

In general, one need to adjust the setmUPSE from Notehead Sets… menu.

(my latest SMuFL font : Mezza STD / Henle like)

Well, that’s good to see! Ignore my other post, then.

it’s ok don’t worry Marc :smiley:

Hello, all. I am the person that reported this issue to Nordine and shared the screenshot. I am a big fan of his fonts and own them all. Several months back, I asked him to create a HENLE-like font, and it didn’t take him long to do just that, masterfully… I do not believe the stem issue is the result of a setting in my application. If I change the default music font to any other, this problem does not occur. One obvious solution is to go to Notation Options > Voices and set unisons with different noteheads to NOT overlap. That’s not the look I am going for. Adjusting the stem connections in the default Notehead set does not solve the problem either. This issue is caused by a width variation between the crotchet and minim, and it is only a problem when these two noteheads overlap; instead of using the stem connections for the wider note, it uses the connections for the narrow one. I was able to work around it by creating a new notehead set that assigns the minim (half) notehead to all notes. So when this scenario appears, I just right-click on the misaligned notes and select the new notehead set for those notes only. Nordine did ask that I contact Daniel about this to see if there was a way for them to address this problem going forward.

1 Like

Chase, you were the first purchaser of Mezzo & Mezza :wink: Thanks for your continuous support and I’m glad that you figure it out! Clever solution indeed :-D, it works like a charm on my D4.

1 Like

I tried without any success to get these notes to align properly in Engrave mode. The only fix I had was to force Dorico to assign the half note notehead to the eights using a new notehead set.

1 Like

It could be fixed in Engrave mode but you’ll have to reduce the size of the half-notehead from 100% to 90%, then you’ll have to adjust the stemUPSE values so that the stem get close the corner of the half-notehead. But this will affect the look of you average score.

I like my way better! :wink:

1 Like

C’est clair! :smiley: