Step input dotted notes, but auto toggle off the dot

During step input to enter a dotted note you have to toggle the dot (obviously):
However, if I then change the note length, say from a quaver to a semi-quaver, the dot remains toggled (i.e. it remains on). I mostly don’t find myself using two dotted notes of different lengths in a row, so I have to un-toggle the dot again (i.e. turn it off), or I accidentally get a dotted note where I didn’t want one. I have been living with this for a long time now, but the extra keystroke is driving me crazy. I know it’s only one keystroke, but I have to do it what seems like hundreds of times per piece.

Is there any way to change the behaviour of the
so that it auto toggles off after one note is entered? Or perhaps after the underlying note length is changed? Either would be an improvement. I have searched settings until my eyes spin but can’t find such a setting if there is one, thanks.