Step input not working properly (Video) SOLVED

I am having a problem with step input, which I don’t use often but have used Cubase for over 20 years and never had an issue before.
I have linked to a short video of the problem.
It seems regardless of the quantize settings, it will only step forward and input notes at 64th notes.

Has my mind gone and I am missing something obvious?
Importantly - Can anybody replicate this or is it just me?


The length of the note is taken from the Length Quantize. Your is set to 1/16 therefore all notes length is 1/16. You probably want to set it to Quantize Link.

Hi Martin
I checked the step input with Cubase on my laptop and it worked first time no problems.
I have found out that the issue I am having on my main studio computer is somehow connected to the adapt zoom function.
Even though that is not available in the key editor when I zoom in and out the note length changes regardless of what I have in the note length box at the top of the editor.
Please see this video.
Can you think of what might be causing this on my main computer?

ps I just checked the list editor, step input works perfectly in there.
It seems it is just the key editor .


In the List Editor, the Adapt to Zoom is not enabled. So to me it seems, when Adapt to Zoom is enabled, the MIDI Note Length follows the Zoom factor (regardless what Length Quantize is set). If Adapt to Zoom is disabled, the Length Quantize is followed.

Myself I find it even logical and I can imagine it’s specified like this.

Sorry I am not quite understanding.
I cannot see adapt to zoom anywhere in the key editor. I have disabled adapt to zoom in the arrange window.
It makes no difference.
Nothing I do will change the type of note that I input except for zooming in and zooming out.

I don’t follow your last sentence.

Do you find this logical?
Are you saying it’s a feature?
I had a quick look on my laptop which I am fairly certain is the same build and everything seemed normal with step input.
Has anyone else seen this before?

OK I just trashed my preferences.
It is working fine now but I just have too much invested in my set up to start again.
By trial and error I have found the issue is contained in my Defaults.xml.
Unfortunately that is where my generic remotes and midi port visibility also reside and I have a complicated set up with lots of ports and controllers.
Is there a way to salvage this situation?

I noticed a while back that changing the note quantize value in the key editor no longer changed the grid.
Quantize continued to work as expected so I never gave it much thought.
It is obviously connected to this issue because after trashing my preferences because the first thing I noticed was the grid changing when I selected a different quantize value.
Step input also worked exactly as expected.
Is there a way to copy my port and generic remote info from my old Defaults.xml in to the new one?

I was dubious as to whether I could just re-import my remote but I went back to my old preferences,
saved the remotes with sensible names and took screen shots of all my ports I/O.
It actually worked and I’m back in business.
I hope this helps someone.


Here (see attached screenshot, please) is the “Adapt to Zoom” option enabled (the mutton is white) in the Key Editor. I saw this in your videos.

Oh hell
I have never seen that button before.
Must have hit it by accident or a random keystroke maybe.
At least I have learned to trash my preferences!