step input / strep record, quantize wont change

Losing my mind here. Im entering some kick drums (not using a drum map) and I’m tying to do it with STEP INPUT.
I have the key editor open full screen, the step input button is orange and active
my Q is set to 1/2 but the entered notes come in as quarter notes.
i switch to Q of 1/16 and the notes enter as quarter notes.

no matter what setting I pick, the entry is quarter notes.

i see the LENGTH but there is no place to SET it… please help/

Well that was frustrating but got it sorted! I had the setting ADAPT TO ZOOM set which “broke” the step input quantize. I also see now the GEAR ICON in the main editor itself allows for the LENGTH QUANTIZE.

I do have one more question. When doing step input, lets say you did a very basic 4 bar measure of whole notes How do you get the BLUE LINE go to back to the beginning of the clip area without having to press arrow keys to the left or manually mouse click back at the beginning?

Not sure it’s possible. Besides opening and closing the Key Editor. Which is why I have requested that the blue line should follow the cursor position.
Feel free to support this thread.
https://www.steinberg.net/forums/viewtopic.php?f=285&t=192225&p=1015493&hilit=Step+input#p1015493