Steps to reproduce Cubase 8 64 bit crash on MidiDevices.bin

I believe I managed to reproduce steps that cause Cubase 8 64 bit version (Windows) crash when reading the content of customized “Midi Devices.bin”. Note that it’s only 64 bit version that crashes, not 32 bit. I also tested Cubase 7.5 (crashes) and 6.5 (works fine).

Problem description

I have a couple of external MIDI instruments and an XML file with their sound definitions. I uploaded the definition file so it can downloaded from Every time I open a song that has a MIDI track referencing the external MIDI instrument, Cubase crashes. So I am mostly using Cubase 6 with my arrangement although I’ve found a workaround: first open Cubase 8, then go to MIDI Manager and delete instrument definitions, then import definitions again, then I can load my song and Cubase will not crash.

Steps to reproduce the problem

  1. Open Cubase 8 64 bit on a Windows machine
  2. Go to MIDI Manager and import instrument definitions from the file that can be downloaded from There are two instuments there (JV-1080 and SC-8850/8820), but it’s sufficient to only load JV-1080.
  3. Assign JV-1080 to one of the available MIDI ports.
  4. Create a new song, add a MIDI track and assign track output to the JV-1080 MIDI port.
  5. Save the song.
  6. Exit Cubase.
  7. Open Cubase again and load the song that you just saved.
  8. Cubase crashes.

Hope the description is sufficient to reproduce and fix this nasty error.

I received a question whether this occurs if I change the audio driver to ASIO4ALL. Yes it does. While experiencing this problem I changed my audio card from M-Audio ProFire 2626 to Steinberg UR44 and also tried switching from the card’s native driver to ASIO4ALL. Still crash.

I installed yesterday Cubase 8.5 at the same uninstalling m-Audio Delta MIDI driver. Then the problem no longer occured. I don’t know if this is because of the Cubase 8.5 or it was a driver related issue, but anyway it works now. I will test with older Cubase (8) to confirm.

I also checked Cubase 8 and it also didn’t crash although it showed first a message box about a “serious error”. So there must be something with that Delta driver.