hi guys .
Any news yet ??
it has been 16 hours and i still have the same problemI HAVE DOWNLOADED THE LATEST SYNCSOFT and when i type in my activation code the damn thing tells me the version is to old and to download the latest one WTF ???
it has been 16 hours now… :smiling_imp: :smiling_imp: :smiling_imp: :smiling_imp: :smiling_imp: :smiling_imp: :smiling_imp:
could Steinberg rent ,steal or borrow some regional servers for a few days ?? they had a super FTP server a while back or even email the damn software to us … all the had to do was put in a attachment zip file to the news mail we all got
or even cancel all the Que and allot customers a server and a window then we could log in and get what we wanted quicker.
for version 11.5 could they try this .
1 pre ordered
2. server assignment to land codeor regional.
email notification when customer has a download window lets say 3 days(failing to comply will reset time window
3.activation is linked to recept of money rg. the proof of transaction has the activation code and link id for syncsoft see point.2.
4.or simply use a cloud base dongle kill this blasted dongle rubish once and for all :imp: :imp: :imp: :imp:

Did you paste the code from your email into the download manager first? I got that message when I put the email code in elicenser, I think they changed it.

i then retyped it no difference
download was good but no lisence… the latest licence from yesterday says its too old to itself …

Yes , if you use the wrong code ie " user error " for not checking the update procedure then you will get this message when try to activate the wrong short code .
As it has been mentioned 8 million times on the forum already you need to enter the code given to you in My Steinberg to receive your activation code .

Simple if you bothered to check first

that was the code i used …
the one on my proof of purchase
the problem is the syncsoft software … it tells me that the version is too old but its the latest version
ahall i give you screenshots ??
this is not my first cubase btw :slight_smile:
i have been around a looooooong time

I guess they’ve changed the authorization process. You first have to activate Cubase 11 in MySteinberg by entering the activation code there. Then you get a license code to be used in the license control center. Not really intuitive. It took me some time to get it working.

Perhaps someone could tell me how I get the Download assistant working. I put in the download code in My Steinberg and downloaded the Download Assistant then launched it. My browser opened and a password window opened and I entered my password … and then nothing, except the another login window came up which bought up another inactive browser page and yet another login. I have checked that I have the right password. I am not sure what to do now. I have logged the problem with support, but don’t expect any help until next week at the earliest. I can’t think whether I have done something wrong, as I have never used the Download Assistant or whether there has been some other issue.

Any advice would be welcome

Hi, go to Windows Settings/Time and Date and press the sync time button. Then try Download Assistant again…

Hope this helps

Thanks i got that ok but i still have this

el controll error

“application"cubase/cubase artist” has caused the following error
process with the id not found…
what now ???

on the left is a menue
dont click on anything exept the redeem one on the right you will see a list of stuff that is included eg cubase 11
halion se etc

you then click one after the other to "download " then when all is downloaded to a pre destined tmp folder you click on install for each of the things in the list
after this they will be marked with a check box.
then the fun starts with the dongle software …
good luck

Tony, sorry I didn’t get this error, so I can’t help. But there is a separate thread about it. Maybe you can get some further hints there.

Thank you for your reply. However, I am not getting the download Assistant at all. I can’t register it because it does not appear in my browser and remains inactive. Obviously I cannot access the Download Assistants menu. Which is currently the limbo I am in. I have uninstalled, reinstalled, changed my password, called it names and thrown my toys out of the pram, but nothing has worked.

emdebee thank you for the sync time suggestion, whether it was meant for me or not it did the trick. My computer is offline except for updating and of course the time was out of sync. I would never have though of it if you had not mentioned it.

hmmm strange !
what browser are you using if i may ask ?

On my music computer I am using both Chrome and Edge. Edge was the one that I eventually connected with the Download Assistant. I tried to connect immediately before the Time Sync and then immediately afterward. The clock was an hour or so out. So quite a significant gap. The elicenser then worked seamlessly too. It is not something I would have though to do, or would have thought to be an answer. Coincidence? …

Yes, my msg was for you - glad the solution worked!

Same issue. I paste my registration code into the elicenser software and I get this:

"The currently installed version of the eLicenser Control (eLC) software is too old.

Please try again after downloading and installing the latest version of the eLicenser Control software from

I am on version:–the latest version. Windows 10, latest updated, clock synced. Completely stuck…


Nevermind, I’m an idiot. Had to use MySteinberg first, and then get it from there. Carry on people…

Jacob , check the forum . The code you were given has to be entered into the left side of of the download manager to give you the activation code . just search the forum you will see it’s a common mistake but everyones getting sorted

I downloaded the Access code and got the activation code. When the Activation code enters the Conrol Center it reports this message to me and I can’t download the license to activate Cubase 11.
“The activation code is intended to be used by software installation programs only. Please either run the appropriate software installation program,or contact your software vendor to get appropriate activation code.”
I am on version:–the latest version
Just after more than 30 attempts, the Elicenser Control Center accepted the activation code and took over the license

all working now ??