Stop bars breaking in half over pages

I’ve imported a file as XML, and Dorico is breaking the music across systems in the middle of bars. I can’t find a setting to stop it doing that.

What am I missing?

I had a case, where a time signature was missing in the XML file. Got some strange results. Perhaps a similar case?

It is an XML import. There’s some weird key sig things as well. Perhaps I need to delete and re-state the time sig.

The only option that controls this is found on the Casting Off page of Layout Options. Dorico will always allow the first bar on a system to break if the system isn’t wide enough to accommodate it (otherwise it couldn’t draw anything at all) but otherwise it should only do so in open meter with this option set, or if there is an explicit break in the bar.

Thanks, Daniel. I think it’s just a messy XML import, so a bit of tidying up to do. The time and key sigs are signposted on some/all staves and need deleting and re-entering. (In fairness, the original Finale document was a mess, too.)