Stop Cubase 11 thinning out hand drawn CC data curves (Modulation, Expression and so on)

Windows 10
Cubase Pro 11

Senario

Open a midi file in Key Editor
Add an Modulation track (CC1)
Using the pencil tool I draw some beautiful flowing curves
I let go of the pencil (take my finger off the left mouse button) and cubase thins out my curves
and makes them ugly and unnatural up and doiwns.

I know that when using a controller to play in this CC Data you can hit F6 > Settings and change the
Return Time, Reduction Level and Spike detection to lower values, and for hardware controllers
this does work.

However I am unable to find any settings for hand drawn CC data - very fruastrating and a work flow killer?

Do you have “Snap” enabled in the MIDI editor?

1 Like

Hi fese

No, snap is turned off so that I can draw the curves free hand.

Hi @KennyEastMids,

did you already try the following?
For you already correctly described the path to go, since it also applies to manual data curve editing.

Manual Writing of Automation Data

…and:

Automation Panel

Reduction level “0” (pls. see Screenshots 2, 3) will leave all manually drawn curve points intact, just tried it in Cubase Pro 12 and it should work the same way in Cubase 11.

Cheers,
Markus

Just in case, three Screenshots:

[- 1 -]

[- 2 -]
Cubase-Pro-Automation-Curve-Data-Thinning-Out-02

[- 3 -]

1 Like

Maybe you can make sure “new controller event” is set to Step rather than Ramp.
grafik

1 Like

↑↑ This, above is about midi continuous controllers, but…

↑↑ This isn’t. Here you refer to project automation.

The question is not hand-drawn vs device recorded. The question should simply be “Why are CC points I drew in removed when I’m done”

And I would have given the same answer as @fese, (double) check your snap setting.

But what I actually think

might be happening is that you are using your controller to write CCs to an Automation Track, because you set that up in the MIDI Controller Automation Setup dialog:

image

If that is the case, write your CCs in the Automation track, rather than the midi part.

1 Like

Hi Markus

Thanks for your reply and suggestions.

I already have all of those setting set to zero for use with my hardware controller
hence my confusion regarding manual drawing of cc data.

1 Like

Hi Johnny

SPOT ON - that fixed it.

How simple was that but I just could not see it.

Thank you, you have saved me a headache.

Hi Steve

Thank you for your reply.

All great suggestions but the answer from Johnny fixed it.

Cheers.

Hi @KennyEastMids,

thanks for writing back, and I’m glad that your problem got resolved by @Johnny_Moneto who’d actually read the additional part of your description that I seem to have missed. :wink:

Best wishes,
Markus

1 Like

Great! now he just needs to find a way to (Johnny) Monetize this!!
:crazy_face: :roll_eyes: :shushing_face:

1 Like

The times that I get paid for this are over. :grin:

1 Like

Hi @steve,

:smiley:

caugh,caugh

Best,
Markus

GRANDPA!

1 Like

You guys are cracking me up :laughing: :laughing:

1 Like