stop playback with marker/automation?

I use Cubase to play backing tracks with a band. It would be nice if I could be hands off and have the playback stop on its own when the song doesn’t have a track. Is there a way to “automate” stopping of playback?

(bedtime here, so I’ll be brief for now :wink: )…
There are two ways (the more complicated one involves using the Generic Remote Device, piloted by a MIDI track that is routed through a MIDI Loop-Back, with a MIDI event on that MIDI track, set to trigger the “Stop” command in the Generic Remote).
The far simpler method is to use Cubase’s Arranger Track, with an Arranger Part set to the same length as the song in question, and set to (the somewhat cryptically-named) “Pause after Repeats”.

Thanks, I’ll look into that. Can I have it stop multiple times? Sometimes I’ll track 10-15 songs per set and I’d like it to stop after the 4th and 8th but keep going the rest of the time.

So I think the Arranger Track case would be ideal for you :wink:
You have all your songs loaded into the same Cubase Project, one after the other? Just create an Arranger Part for each, and for those where you want Cubase to Stop at the end, use the “Pause after Repeats” option that I mentioned earlier. When you next hit “Play”, the cursor will jump to the start of the next Arranger Part in the Arranger Track List, and Play from there.
For the other songs where you want it to continue, use instead the option “Normal”.
If you want a fixed amount of silence between songs that otherwise “continue”… presumably you have already taken care of that by the actual distance between the songs?.. then create Arranger Parts for the silences also (or include the silence after a song into the length of the Arranger Part for the song itself :wink: )
Using this method, you can also change the set order without having to change the order of the songs in Cubase itself (just change the order of the Arranger Parts in the Arranger Track List :wink: )

I had played around with this about a year ago and for some reason decided not to go that route but I’m going to use it on the next gig. Tried it out last night.

Looks like there’s a way to “bail out” of a sequence of songs as well and tell it to end after it finishes the current arranger track that it’s on.

Thank you. You get exactly what I’m using this for… and it will allow me to restructure a set on the fly which may prove quite useful.

I remember now why I went in a different direction before. I was using Cubase to record the gigs as well as playback of tracks and every time the arranger track jumped Cubase dropped out of record mode.

I’m not recording the gigs that way anymore so that problem is NA.

When I start a new section on the arranger track after a “pause after repeat”, I get a stutter for a couple of clicks. Anyone have a similar problem? Is there a preferences setting or something that can influence that?

It might be that I’m using my Dante Network through my house network vs. my dedicated gig network (in the trailer). I’ll know after tomorrow’s gig I guess.

Are you using ASIO Guard for any VST Instruments/plug-ins? (try turning it off).
Is it critical that the song start exactly when you hit Play? If not, try creating a very short arranger Part (say, 2 beats), and add it to the start of each song.

turning off asio guard made no difference.

I need to refine my explanation. What I thought was “stuttering” is not really what is happening.

I left a measure between songs in my set list to make it easier to tell when where the songs start/end (screen shot 1). In this scenario: During playback from the arranger track AND the arranger track ends a song AND that arranger “section” is set to “pause after repeats” AND it automatically advances to the next and waits, if I press the spacebar to start the next arranger “section” of the song/set, the audio track (cue track) starts correctly but the midi track(s) start 6 beats into the current arranger “section” and play for 2 beats. Then the midi track(s) “jump” backwards to sync up with the audio track which is now on beat 3 of the count off and playback is normal.

If I close the gap between the arranger “sections”, it doesn’t do the above.

If I select the arranger “section” I want to play with the mouse from the left panel of the arranger window (as opposed to just letting the arranger track go to it and wait) the track starts just fine without the above behavior.


I suppose I could go back and butt up the 15 songs in this set (or spend a big chunk of time with some other DAW more live playback orientated - but I’m good with Cubase and don’t want to do that) back to back but it seems like it shouldn’t act like this.

What am I missing here?
screen shot 2.jpg
screen shot 1.jpg

Hmmmm, very strange… I don’t really know what is happening there.
(I’m afraid my eyesight doesn’t allow me to make very much… other than a bit of guesswork… of those two screenshots, which are still small here when expanded).
However (just a wild guess… I’ve no idea if it will help)… Do I see a Tempo change right at the start of each song? If so, does it make any difference if you move the tempo events a bit earlier, i.e. in the silence between the songs (or try even putting the tempo event for the next song at the end of the previous song)?

I appreciate the help and your persistence. Nope, moving the tempo change back didn’t help either.

I have this gig tonight where I need the tracks to be hands off which is why I haven’t given up on this concept. So far, except for the first two beats of each count off, it works. The audio track plays correctly so that’s a plus. The midi click plays in tempo (six beats ahead and then jumps back) but when it jumps back it “drops” one of the clicks. I’m not sure how big a deal that is going to be to the band as we all listen to that click at various volume levels. I’m not comfortable doing a gig with a known problem with the tracks/automation but I’m out of time.

Why it behaves differently when the arranger “sections” are butted up back to back seems very odd but I guess that’s the way it is.

If you think of anything let me know. I’ll post if the wheels stay on for the gig or if they come off. I guess I can always turn the arranger track off and “man the laptop” myself if it gets that bad.

I can merely suggest a couple of things to troubleshoot…
(just for testing purposes, of course :wink: )…
Try deactivating VST Instruments/plugins one at a time… see if one of them is the root of the problem.
Automation? (try bypassing).

When you have the time, PM me with a stripped-down Project (that won’t cause you any copyright problems :wink: )… containing just enough for the problem to manifest itself… I’ll see if anything comes to mind once i actually have the thing in front of me.

Good luck with the gig :wink:.

Will do.