Stopped seeing my audio device...why the sudden hate?

I’m pretty new to this stuff, and I’m on Cubase 5. On Windows7, using a TASCAM US-200 soundcard. Until recently, everything would work perfectly. I’d start Cubase and not have any problems. However, for some reason, now every time I open Cubase, I get this “Missing ports” notification, that I don’t know what to do with.
It basically tells me the In ports are unmapped for the US-200 device.
The device works fine in any other program, windows can register the XLR mic and I play my music through the device through media players. The problem occurs in Cubase only.

In my VST Connections, in the Outputs tab everything seems fine and I can find and select the device…
…but in the Inputs tab, it lets me see the device from a dropdown menu, but doesn’t let me select it! It’s super weird! :confused:
And I’ve made sure to select the US-200 ASIO driver in my VST audio system tab in the Device Setup window.
I’ve tried checking and unchecking the “Release driver when application is in background” box - no difference.
I’ve tried starting Cubase with the device plugged in, and also tried plugging in after starting the program - no difference. The device is on and working everywhere else.
Can anyone explain what’s happening? I can’t figure out why Cubase doesn’t wanna see the device anymore.

Please help!