Strange behavior with duplicate tracks and certain FX plugins

This is probably me being ignorant but since I’ve spent a good deal of time on it and can’t quite figure it out, I thought I would ask for advice.

I am doing parallel compression by sending a dry signal out of a Group to an Effect Track.
This Effect Track then goes straight to the Stereo Out. I’ve setup a good balance.

The original signal goes to another Group before going to Stereo Out. Everything sounds great until I add Magneto II as an insert to this group. Now the sound changes drastically for the worse.

I initially thought it was a phase issue, but it turns out that the Frequency Range knobs on Magneto II now suddenly works as EQ on the total sum of the sound from the original+compressed signals. It does not only control what frequencies should be affected by saturation, but it really does EQ the entire sound.

A workaround is to add Magneto II do the insert of the Effects Track too which contain the duplicated compressed signal. Then everything goes back to normal and works as expected.

I don’t think it is a bug because I’ve found the same behavior with Waves Kramer Master Tape and there might be others too (most saturation plugins do not cause this effects however). I know the Kramer Master Tape is a multi mono mode plugin which could be the case for Magneto II too - but I don’t really understand if that has anything to do with it.

I suspect that it is something I’ve overlooked or don’t understand about this setup. Any advice would be highly appreciated.

If you want to perform parallel compression, I would stick to a compressor and not an emulation of a tape machine. It does not surprise me the slightest that that those plugins alter the tonality of the signal that in turn causes phase cancellations in your parallel path.


@mlindeb Thank you very much for the reply. I am using only a normal compressor on the compressed signal. As I want this dry I then route it do the Stereo Out.

I do want to add some saturation on the original signal however that I don’t feel I need on the compressed signal. That is when the issue happens but only with certain plugins like Magneto II and Kramer Master Tape.

So basically the setup is:

Group 1. Sending the signal via a Send to FX Track 1. Routed to Group 2.
FX Track 1. Compressor. Routed to Stereo Out.
Group 2. Adding reverb and Magneto II (as plugin or via Channel Strip does not matter). Routed to Stereo Out.

Adding Magneto II onto Group 2 change the entire sound on the Stereo Out. The Frequency Range on Magneto II now works as an EQ for the entire signal instead of just being the range which is saturated which is the normal functionality.

Adding Magneto II to FX Track 1 as well as Group 2 solves everything and functionality goes back to normal. But I really don’t understand why and don’t really want to add saturation to the compressed signal.

You don’t event need to use Group and FX Tracks.
Just duplicate the track and add the plugin as an insert on one track.

I have just thoroughly tested it, and it appears that it is indeed not a bug.
What happens is that the plugin shifts the phase at the crossover point, and this is what makes the phasing effect when you tweak the frequency knob.
If you had tried turning the freq controls completely to the min or max, the issue goes away, because it goes back into phase (no shifting occurs).
Kramer Tape effectively does the same thing, although it has no frequency control but there are two fixed options with the Speed switch.

Actually, any multi-band plugin does that, even if there’s no processing happening.
For example Unfiltered Audio Triad, without any effect module loaded.
Just move the bands around and it shifts the phase, but you obviously don’t hear it at all when using it on a single track. This becomes an issue only when trying to do parallel processing.

1 Like

Yep, tape sims tend to mess with the phase… If they don’t, they are not properly coded, because that’s what tape (apparently, haven’t actually verified myself :wink: ) does.
With magneto it is probably not the correct tape simulation but more the effect of the filter, as @Louis_R wrote.
A lot of saturators and non-linear processes do mess with the signal and do icky phase stuff, if they use minimum phase filters for whatever purpose (crossovers, EQ)
Your options are either to find some that don’t as much or put the processors on both parallel paths, as you already did.


@Louis_R Thank you for all the great information. So, it is a phase issue then - which I suspected initially until I dismissed it. You are right, the issue goes away if I tweak Magneto II so the frequencies are set to the full range 20-20kHz. That is in fact the reason I (wrongly) stopped believing it was a phase issue.

Unfortunately, in my setup I do need to use Group Tracks. I only described the small relevant portion of my larger orchestral template.
Basically, I have a large number of Instrument VST Tracks which are summed into a Group Track for each instrument category, in this case a Strings STEM group. I want to do parallel compression on this Group. If I insert a compressor on the Strings Group and use the wet/dry to do parallel compression, then the compressed signal also will the reverb on the send which I don’t want.
So instead, I do send the signal to a separate FX Track where I do the compression.

The Strings STEM Group then goes into a new Group which SUMs the entire orchestra where I add a Reverb tail and would also like to add a bit of saturation. That is when I ran into the phase issue. Not yet sure how to solve it. Using various Softube Saturation plugins work fine but I do feel now that the setup is less than ideal, so it is probably better to address that rather than just replacing the saturation plugin used.

@fese Thank you for your help! I’ve found that most saturation plugins did not create this issue. I have quite a few :slight_smile:
The two saturation plugins I’ve found where this happens are Magneto II and Kramer Master Tape. But I think with your and @Louis_R feedback the entire setup that I use in my template is probably not ideal so I should consider another way of going about it, if there is one.