Strange behaviour with midi remote script (12.0.10)

Hi all,

Since the last update, I’m experimenting some strange problems with my Novation Launchkey 37 midi controller when I load a Cubase 12 project,
There is a bad interaction between the script and Cubase.
Sometimes I lose the transport functions on the Novation and the large level meter of Cubase shows an increased background noise (with no lag).
The restless peak value in the metering disapear as soon as I play/stop the project.

I didn’t have any problem with the default Launchkey script with Cubase 12.0 so I’m sure it was introduced with the 12.0.10 update.

Maybe the default script has be changed ?
If the Novation is unplugged, there’s no more level meter bug display so the midi remote function seems to be concerned.

Sorry for my bad English, hope you will understand.

First screenshot with script desactivated
Second one with script activated
(VSTi is not played, restless peak value)

I progress in my investigations :
If I open a project previously saved with an instrument track selected, it will open with this bug described above.

If I open the same project with an other kind of track selected before saving there’s no noise and the restless peak value is normal.

Hope it helps…

EDIT : I use 2 USB devices (Nord Piano 4 as an external instrument+ Novation Launchkey 37).
If one of them is not connected when I load a project who use both that cause a peak value bug or I’m ejected. Very frustrating…

Is it the Launchkey 37 that has “factory” script support? Then I might know what’s going on:

After the MIDI Remote system has activated the script (when loading the project), the Launchkey sends a note to the DAW to acknowledge that DAW mode has been turned on. That is probably what leads to that peak value bug. We have addressed that problem for the next maintenance update. Let me check on my Launchkey 49 to be sure…

1 Like

Yes I use the factory script and effectively the bug appears once the project is loaded and the script activated…

The peak value bug always come from a VSTi track (like HAlion SE).
I think this bug was introduced with 12.0.10 update beacause I didn’t noticed that with 12.0.

That’s true, sorry for that.

The main thing is that you are aware, I suppose it will be fixed soon in the next update.

Problem solved with 12.0.20

Thanks !


EDIT ; Sorry but I have spoken prematurely, the problem is not solved :it’s even worse !
Now it can occur while the song is playing.

Here are 2 pictures : the first one once the project is loaded

The second one while the song is playing.

Very frustrating !

1 Like

There’s no rule to reproduce the bug : with the same project one time it will load correctly, the other time it will load with the bug.

I’m sure it’s a problem with the midi remote function because if I unplug the Launchkey there’s no matter at all (I use a Nord Piano 4 too connected as an external instrument without any problem).
I own an old configuration (Q6600 + 8 GO) but I had no problem with Cubase 12.0.
Did you manage to reproduce the bug ?