strange behaviours of dynamic placement in Dorico 3.x

Dear users and developers,

I have been experiencing strange behaviours of dynamic placement in Dorico 3.x too often.
Please look at the following screenshot:
Screen Shot 2020-01-24 at 20.00.52.png
As you see, the dynamic marking is placed below the staff, but the property shows it is placed above staff.
I also cannot deactivate the placement switch.

There are too many same behaviours.

How can I make Dorico interacts as usual?

PyoungRyang, you need to attach a project in which this goes wrong, not a picture.

My guess is that this is a dynamic that was created by way of MusicXML import, but since you provide no other details and no project file, we’re forced to guess. It will save both you and me time if you provide a minimal project that exhibits the problem. Copy and paste those few bars to another project. If the problem persists there, then zip up that minimal project and attach it here. Then we can give you the answer you need.

Yes, the dynamic markings created by MusicXML import have the problem.

I am sorry for not having submitted a zipped Dorico project file because the project file is too big (more than 100 pages with more than 10 flows).

I am attaching a zipped project which includes two examples of dynamic markings (both of them are imported from musicXML files).

I switched off the placement option.
The problem is that the placement of the second dynamic marking is “above” staff, but it is placed “below” staff.
It was originally placed “above” staff. It moved its position “below” staff as I switched off the placement option.

Please watch the following video:
https://www.dropbox.com/s/199nlll5z95d12k/dynamic%20placement.mov?dl=0

I expect a small sample of the problem in a Dorico file would be even more valuable than a video.

Oh. Sorry!
test.dorico.zip (690 KB)

Yes, a video is really only a moving picture, so still has all of the same disadvantages. There is a reason why we ask for a project file to be attached and not a picture or a video (or a rough pencil drawing, or a 100 word description, or an excerpt of an audio book, etc…) – it’s because we can quickly diagnose problems from Dorico projects and we have to guess with everything else. The absolute best thing you can do is what you have done in your most recent reply, and as I asked you to in my original reply: copy and paste a tiny bit of the music to another project so you have a minimal case to reproduce the problem, then attach that. It really, really helps.

Now, the answer to your original question:

When Dorico imports a MusicXML file, it does so in such a way that properties that would normally be set on a per-layout basis get set globally, i.e. the value will apply to all layouts. The Properties panel expects each property to be set with only a single scope, which is defined internally in the software. However, many properties can technically be set with a different scope, though not from the user interface as it stands. (This is why we currently require Edit > Propagate Properties.)

When Dorico encounters a dynamic with forced placement in a MusicXML file, it sets the ‘Placement’ property. But no layouts exist at that point, so Dorico sets the property for all layouts. The Properties panel doesn’t know how to handle this: it can tell the property is set, so it’s shown as activated, but when you try to switch it off, its rules for how it expects to be able to determine the scope of the property are violated, so it doesn’t work.

To work around this, you should do Edit > Reset Position on the dynamic, which will clear this “global” property and allow you to set it on a per-layout basis as usual once more.

For the purposes of future MusicXML imports, it’s worth going to Preferences > MusicXML Import > Other Notations and unticking “Dynamics Placement” (and preferably most of the other options in this dialog). Note that these options only affect MusicXML files that you import into a project, not MusicXML files that you open in Dorico.

Yes, in general I would recommend switching off as many of those options as you feel comfortable with. The more of those options that are switched off, the closer to how the music would behave if you simply entered it directly into Dorico using its note input features you will get.

Thank you for your quick and kind explanations!
The problem is resolved!

I also unticked “Dynamics Placement” and others! Thanks!