Strange engraving behaviour – help!

Hi!

Please have a look on this video (zip).
Video klein gekürzt.mov.zip (1.01 MB)
What I want to do is dragging the framed text box a little to the left.

What I am doing in the video:
clicking 3 times opt–left arrow, than 3 times command-z (undo)

I don’t know why the other elements in the score are moving as well. Undo increases the problem. There is no difference if I drag the text element with my mouse or use the properties panel. My only solution is quitting Dorico and reopen the file. But there is no chance to move the text box. What is going on here?

Thanks in advance!
Textbox problem.dorico.zip (1.14 MB)

Select the text box, and in Engrave mode–Properties panel, toggle “Avoid collisions” so the box is unchecked. Then you can move it as needed.

This sort of issue has come up before in regards to Rehearsal Marks. I think most of those issues were fixed, but this seems like a slight variation. Anyways, removing collision avoidance fixes it.

Dear dankreider!
Thanks a lot for your help. :slight_smile:
Interestingly it doesn’t work for me.


Am I doing something wrong?
I could drag these text elements for weeks now without any complication – but today …?

What version of Dorico are you using? There was an issue in an earlier version that sometimes, edits would cause vertical spacing to increase with every action, including undo. You should find that closing and reopening the project returns objects to their correct positions.

In 3.5.10 here, moving that tempo equation at bar 24 doesn’t cause spacing issues.

Hi Lillie!
Thanks for your help!
I am using the latest version of Dorico, 3.5.10. I wonder, that this never happenend before in my project. I could drag these framed text boxes around where ever I wanted. But today everything is different! :wink:
Its just the text box for bar 24, no other text box shows this behaviour. Strange …
I found a workaround, which is – you know – a workaround and not a solution: i have to attach the textbox somewhere else than close to the barline. Look here:


So its a workaround and ok as long as there is no page break in the score or system break in the single score …

Next topic:
Look here, same bar, same strange behaviour. I want to flip a slur (don’t know why there are many slurs at the wrong position after setting the score from »in c« to »transposed« as you also can see in bar 24). It causes the same problem – just in this particular position, other slurs don’t affect any problems.
Bildschirmvideo aufnehmen 2020-09-22 um 18.17.33.zip (505 KB)

Next hint:
There is NO problem in a transposed score (sorry, I mixed it up in my last post), the problem ONLY occurs in a non transposed score.

I can’t see what you’re seeing here on my machine (perhaps due to me having different fonts) but from your project that you shared earlier, it looks like all the slurs in these bars around b24 have their direction set explicitly - that might be why they’re not automatically adjusting when you change from Concert to Transposed pitch.

Based on how the tuplet bracket keeps getting higher with each action, it does look like the issue I mentioned that, if I remember correctly from last time it came up, is a bit hard to pin down. Saving, closing, and reopening the project should return everything to their expected positions. (I’ve experienced it once myself!)

Yes, you might be right, I had to set the slurs explicitly cause their directions were wrong in the c-score (maybe thats a result of the xml-import from sib, I am just correcting and engraving this project, I am not the composer).

But: there is no change in the strange tuplet behaviour after closing and reopening the project. The problem occurs every time. But ok, there is a workaround. :wink:

Rather than correcting incorrect slurs, reset them. Just select all, filter slurs and turn off their explicit direction. If that doesn’t work, with the slurs still selected go Edit > Reset Design and Edit > Reset Position.
Better still, set your MusicXML Import Preferences (from Dorico’s Preferences > MusicXML) in such a way that Dorico doesn’t respect the slur directions in the MusicXML file. It’ll save you hours in the long run.

Thx pianoleo! :slight_smile:

This behavior surely happens in 3.5.1 with me too with some elements.
But way less than before for sure.
It still seems quite random