Strange instance of Group Dynamics misaligning dynamics


I just stumbled upon a weird example of Group Dynamics not working properly.

I’m trying to align the following two lines of dynamics horizontally. This is the result I get when I ungroup them:

But whether I group all of them together or I group each line separately, I get this result:

I don’t understand why the first group isn’t horizontally aligned like the second group is. Am I doing something wrong or is this a bug?

EDIT: using Align Dynamics in Engrave Mode worked, but the first group is still not aligned with the second group:

If grouping isn’t producing the correct alignment, is it possible the endpoint of a hairpin isn’t exactly where it should be? It could be a bit too long and look exactly the same.

Perhaps I should recreate these dynamics and see what happens then?

I would try selecting all the dynamics. Ungrouping them and then regrouping.

Unfortunately, I got the same result.

I’ve had this happen before. I’m almost positive it’s the result of a dodgy interaction between Group (in Write mode) and Align (in Engrave mode).

If you avoid “Align dynamics” completely, you’ll never have this problem. Just group them. This one you may have to delete and re-input.