Strange issue using sequencer and real-time export

Hi,
I am using an Akai MPC1000 sequencer to trigger Superior Drummer and Halion. When I mix down audio, I do a real time export so that the sequencer sends the appropriate midi notes to the VSTs.

Everything syncs up fine and I was having no problems until today.

With one of my projects, when I play back the project (including the sequencer simultaneously), everything is lining up and all the notes are in their proper place.

However, when I do a real-time export, there is a slight lag before Cubase starts to play compared to the sequencer. This results in the samples triggered by midi being about a quarter of a bar ahead of the audio tracks.

I have checked on my other projects and this is not the behaviour: the output after real-time export is the same as when I just press play.

I have no idea why on this one project there is a slight lag in the audio before it starts to play, whereas the midi-triggered samples begin immediately after I hit real-time export. To reiterate, this is not the case when I just play back the project.

I am aware of solutions such as just laying down the midi track within Cubase 8, or rendering the midi tracks before doing an export.

However, I just want to know why there is a lag on one project. I would have assumed this would be across projects, but it only occurs on one.

Is there some setting I might have accidentally turned on? :unamused:

Hi,

It’s hard to guess. There is a Track Delay on every single track. Isn’t it enabled by accident?

Maybe there is an issue with plugin delay compensation…some plug is misreporting latency to Cubase??

Thank you for the responses.

Sorry, I wasn’t aware there is a setting for track delay on every single track. Where exactly do I find this tool?

Also, not sure I was clear in my original post. If I play back the track normally, the sequencer timing (and the bar/beat meter on the sequencer) is in sync with the Cubase timing.

If I try to export however, there is a delay of about 1/2 bar before Cubase starts to play. The sequencer on the other hand, starts to play immediately, resulting in the discrepancy in the timing on the resultant audio file.

Could this also be linked to the track delay setting you mentioned?

Hi, this seems possible, but I’m not sure how I would narrow down on this.

I have attempted to create an entirely new instrument for the midi files, but the resultant is the same: on real-time export, the sequencer begins to play before the rest of the Cubase project begins to.




As mentioned, guys, this is only happening on a single project. Everything works well on my other projects. Going nuts trying to figure out what is happening! Appreciate any help!

Here’s a short video demonstrating the problem. I can’t figure out what is going on. If you keep count with the meter in the first bit of the video, you’ll see what I mean about it being in sync. In the second part, you’ll see Cubase running slower than the sequencer.

https://www.youtube.com/watch?v=uy8uy6gv6Kw

I am having the same problem in Cubase Pro 8. Since a few days, Cubase has been very ‘laggy’: when i hit play on the transport, playback would sometimes only start 5 seconds later. Today, i started a new project. I programmed some kicklayers and hats in Cubase, it was sounding allright. Then i turn on my Cirklon to trigger some hats from my modular and this appears completely out of sync with the sounds i have going on in Cubase. What is funny, is that it is not the Cirklon and the modular that are out of sync. It seems that the sounds being triggered in Cubase are about 1/16 ahead of the click. How on earth is that possible? PDC indeed? I checked the slider in the inspector to see if there are any timing offsets there: none. I have no idea what is causing this. I recently updated Cubase Pro 8 to 8.0.40