Strange Issue With Note Input

Hi. After a long “vacation” from Dorico V1.x where I was moderately skilled with V1.x, I’m diving back into V3.5. I fully admit that I’m very rusty with Dorico, but I’m seeing some weird issues performing note input with V3.5.

Right now I’m trying to modify a score created from an imported music XML file. After double-clicking in a bar with three current quarter notes (see first attached image), an insert bar appears. Pressing the “C” key on my midi keyboard causes a “gray” note to appear (see second attached image). This may seem like an incredibly basic question, but I can’t figure out how to permanently enter that note. Any action that I take causes the note to disappear (see first image again).

I’ve looked at the docs, but can’t find an answer. Can someone give me some pointers?



p.s. I’ve tried all the standard debug approaches, including restarting Dorico, restarting the workstation, re-importing the MusicXML file, and copying the score to a new, blank score. Nothing worked.

DoricoProblemBefore.pdf (8.1 KB) DoricoProblemAfter.pdf (9.8 KB)

To ensure that the PDF files don’t give people issues, I’ve uploaded JPEG images too:

DoricoProblemBefore DoricoProblemAfter

Well, this is fun… After rebooting my workstation once more, I tried entering the last note in that bar again. I say last note because the score is set to 4/4 time.

That worked, sort of… But it kept adding more than 4 quarter notes before deciding to add an eighth note before creating a new bar. (See image below.) This is weird. Has anyone else seen this?



You probably are in input-pitch-first mode. Press k to toggle to input-duration-first.
In pitch-first mode, you choose the pitch (grey note) and write it when you choose the duration of that pitch.
Hope it helps!

Yes, if you’re seeing a shadow note after pressing the pitch letter on your keyboard, that sounds like pitch-before-duration. You can read a bit more about that here, but for duration-then-pitch input, see here.

Dorico will add bars if needed based on the duration of the notes you’re inputting - and by default, you can select other durations by pressing the numbers 1-9 on your computer keyboard. 6 is a crotchet (quarter note), 5 is a quaver (eighth note), 7 is a minim (half note).

One way you can tell is by seeing which buttons are highlighted (“active”) in the Notes toolbox on the left of the window.

1 Like

Mark, Lillie,

First, thanks for the feedback.

I changed the settings to “duration then pitch” mode. The good news is that this worked. Sort of… (See below for the issues.) I had to attach an external number keypad to make that work. And to make things easier, I just bought a Stream Deck profile for Dorico . (See more in the postscript below.)

That said, I’m still seeing strange issues with Dorico…

Since the score is in 4/4 time and a quarter note was selected and by playing “C”, I expected to see a quarter note inserted as the third note in that bar (see first Dorico screenshot below). Instead, it inserts two eighth notes and an eighth rest (see second Dorico screenshot below).

I think I’m doing something wrong, but I’m not sure what. Feedback humbly requested.



p.s. With only maybe 20 minutes working with the Dorico Stream Deck profile, I love it. For experienced Dorico users, it might not be useful. But for 3.5 newbs like me, it’s awsome. For example, instead of pressing a “6” on the num pad to select a quarter note in the Dorico Notes menu, you just press the quarter note button on the Stream Deck “Notes” page (top row, second button in the first Stream Deck image). See pics below, and here is the software link for Notation Express XL Stream Deck Profile for Dorico.

---- Pics ----

Before adding new note:

After adding new note:

My Stream Deck:

The time signatures in your MusicXML file are almost definitely wonky, for want of a better word. I’m somewhat surprised that no-one’s mentioned that already, given there are clearly more beats in each of your screenshots than the prevailing time signature would typically allow.

For starters, try deleting the red time signature signposts. If they won’t delete, try selecting and deleting the barline that precedes each red time signature.
Then go back to wherever the 4/4 is supposed to start, and re-enter it again (either using the popover or from the Stream Deck - whichever you prefer).

P.S. I’m glad you’re finding Notation Express useful.

@BookemDanno , You entered that quarter note halfway through the third beat. What I wonder is not why you have the tied eighths but why no eighth rest showed up between the final quarter and the tied eighths.

Leo, Derrek,

I think that Leo nailed it perfectly when he said that the MusicXML is “wonky.” I tried his suggestions, but not much changed. Then I reimported the score using a MIDI file and had similar issues.

Leo, I have no clue as to why it was acting like that. Doesn’t make sense to me.

So I wrote the whole thing off and hand-entered the score. Using the Stream Deck and Notation Express, it went very quickly. Even with my limited experience with those two tools, I was surprised how smoothly it proceeded.

Thanks again for the comments.

Best regards,


Next time do feel free to share the MusicXML, or a cutdown version of it or something; it’s normally fairly quick for one of us old-timers to fix these sorts of time signature errors.


Thanks. Will do.