Strange jumping

I have the Dorico window reduced to the top half of the monitor and when I select something at the top of the window, the view immediately jumps down to place the selection at the bottom of the window. The zoom is set to 151%. Anything I can do to avoid this?

I experience the same thing. I click on something near the top that appears to be well within the viewport, but Dorico insists on scrolling way up as if it isn’t.

Out of interest, I see that there is a Frame Break in bar 16, which is now at the top of the screen. What happens if you move that to, say, bar 17 or any other bar?

@Mark_Johnson This appears to be a feature because the same thing happens with full screen if an element is selected that is close to the top of the window whereupon the music jumps downward. I guess it is designed to center what is being edited, but it doesn’t take account of windows that are not fully open. That is, it thinks the window is fully open when it isn’t and throws the. music out of the window, I am also seeing some inconsistency in the way it operates. Sometimes it jumps and sometimes not, and with the same element being selected. @Beechside, the frame break doesn’t seem to make any difference. The same thing happens on systems without frame breaks.)

I wish there were a way to turn off the automatic repositioning. I am finding it counterproductive when editing, which is not a linear process.