Strange Key Editor / Ex Map Behavior

Finally have a bit of time to mess with D5 and I’ve run into something strange with the Key Editor and Expression Maps.

I have a Flute track (see image). Note that I have assigned staccatos to the first note in Bar 2 and the last note in Bar 3.

Regarding the last note in Bar 3, you cannot see the Ex Map poput, but it correctly shows Dorico applying the “Staccato” base and it plays back correctly.

But look at the Bar 2 first note. You can see in the notation that staccato is assigned, yet:

  1. The Ex Map lane shows Natural
  2. Natural plays back in my VST instrument.
  3. But the Playback Length is shortened by 50% per my Playback Options, which indicates that Dorico recognizes properly recognizes the notated staccato.

I already added a blank Bar 1 to see if that solved any potential problem with the Ex Map trigger, but the problem persists.

I don’t think this is a problem: if there’s no staccato switch in the expression map, you won’t see an entry in the playing techniques lane. The staccato is rendered purely as a MIDI effect, rather than by selecting another sound, so there’s no change in the active playing techniques.

Daniel,

Thanks. I hope against hope that you are able to get some sleep overnight instead of responding to problems. You da man, but we need you to keep being da man. I am in no hurry.

There are still a couple of facts that at least for me defy explanation unless there is a bug.

  1. If this is true for the first staccato, the second staccato does indeed show “Staccato” in the Ex Map lane (I know you can’t see this in my screen capture because the note length does not allow it), so if your suggestion is correct then the behavior is inconsistent.

  2. The first staccato does not play back as a staccato, it plays back (meaning in the Synchron Player) as a Natural, which I have assigned as Long Note > Regular.

I hope you are right and I’m just seeing things wrong.

Thanks as always, and I’ll say again, get some sleep.

3 Likes

If you want me to provide any further insight (if you can call it that!), please provide a minimal project so that I can take a look at what is actually happening.

if you’re using the VSL SE library, I could probably try to replicate this, given the project. Obviously I’d need to see which map you’re using as well as it’s not likely to be mine – in particular how the NoteLength definitions have been programmed.

Daniel,
Will do. It will probably be Monday since Sunday always takes what energy I have. The project is minimal at this point since it’s more an attempt to play around with custom instruments. It does connect to five instances of VE Pro.

dko22,
the project at this point only includes a few VSL Woodwind instruments added as part of the new custom instruments feature. It includes both Synchron and Synchron-ized instruments.

Thanks to both of you.

Here’s the file. Reference my original post for a detailing of the problem.

D5 VEP - Set Up June 2023 - Current Version.dorico (1.0 MB)

Edited to add:

The file contains five VST connections to instances in a VE Pro Server file.

The VE Pro instrument connected with the Dorico instrument Flute 1 .s is VSL Synchron Flute 1.

I can duplicate this issue. It seems that there is a hard timing rule where Dorico will use key switches or not for staccato. The cutoff seems to be for tempo >= 120 for quarter notes or tempo >= 60 for eights notes… Change your tempo to 120 and this will work as you expect. Or use eights notes for staccato is you want key switches for tempo of 75.

There may be a setting that allows you to adjust this but I was not able to find it.

1 Like

Is this affected by the playback options>timing> maximum duration for staccato playback technique?

yes, it’s to do with playback options>timing> maximum duration for staccato playback technique exactly as Janus says. Change the value there to a minim and I think the problem goes away. The behaviour is not completely consistent, though, as sometimes there is still a delay in the Key Editor technique updating if you change the note length. But I’ve come across this sort of thing often enough in the past.

The problem is that it’s not just the note value but also the actual tempo which need to be taken into account so @dlb is also correct.

Wow. I never would have figured that out. I’ll tinker with things some more.

Thanks so much dlb and dko22.

So I changed the note values of both staccato notes and see how you are correct.

At a tempo of q=119 any time a quarter note is set to staccato it is treated as a Natural. The same notes changed to eighth notes are treated properly as staccatos.

But change the tempo to q=120 and even the quarter notes are treated as staccatos.

So for Play mode purposes at this time one has to notate quarter note staccatos as eighth notes for tempos slower than 120.

Hopefully this can be fixed at some point, understanding that this is but one bug among a list of competing things.

It’s not a bug. It’s designed to work this way. And if you think about it it makes a lot of sense. At some point you don’t want sampled shorts to be played for long notes marked as staccato. But you do want them to be shortened. So that is what happens. It’s adjustable with the timing parameters mentioned above.

I suppose so. Designers have to make choices.

In this case for me it was an experimental situation where I really didn’t want to notate the quarter note as staccato, I just did for testing purposes. At least I learned something.

Thanks again.