Strange lane behavior in Cubase 6.0.1 Pre-release (Windows)

Seeing something really strange after cutting up several takes on an audio track using cycle recording - basically what happens is that after I save and reload the project, the audio track with the takes that were previously cut suddenly has double the number of lanes (with the pieces of the cut audio for every take alternating between the original lane and a newly added lane below it). Probably easier to explain by looking at the before and after screen-shots I included - here are the steps to reproduce this (happens in both 32bit and 64bit versions):

  1. Create an empty project and add an audio track.
  2. Click the “Show Lanes” button on the track and setup a loop for cycle recording.
  3. Record a few takes then cut up the takes at random locations(+ Left mouse click on a PC).
  4. Everything should be fine at this point, but now save the project, close it, then reload. You’ll now see the track has the additional lanes.

I confirmed that the audio parts are not overlapping. Didn’t see this problem in 6.0 so I’m assuming it’s a newly introduced bug - can someone else confirm the same?

Thanks,
Johnny
Lanes before.jpg
Lanes after.jpg

…forgot to mention that my OS is Windows Vista 64bit (SP1).

Yes I have seen this happening with 6.0.0
But I can’t get your repro to work…

Hmmmm interesting because I can reproduce this every time. Did you test it in the 6.0.1 pre-release version? What OS are you using?

Windows XP with cubase 6.0.1 here…

I tried and tried but can’t get it to happen on intentionally.

When the extra lanes appear, you could try examining the start position and lengths of the segments in the info line…
Maybe they have moved or changed lengths?

Maybe someone else can reproduce it?

Using Cubase 6.02 with Windows 7 (64 bit OS but 32 bit version of Cubase), I’m getting similar behavior: every time I make a cut with the scissors, a new lane is unnecessarily created with one segment of the split part getting its own new lane for no reason. And I can’t make it stop. I’ve been trying to comp a few takes of guitar parts, and I’ve now got something like 321 lanes!

Hi - I get the exact same problem using Cubase 6.0.2 on Mac OS X 10.6.7!!

It’s driving me nuts - Every time I save, close, re-open a project in which I have split audio events - I end up with extra lanes being created to accomodate each bit of split audio. I can’t see any advantage in this at all - it just makes my work area more clutered and difficult to work with. I end up having to drag all the parts into the lanes where I actually want them to be just to see things more clearly (and, in so doing, also havign to contend with the other new comping “features” such as accidently activating an event that I don’t want to activate!). That’s fine until I save, close and re-open again and evrythings reverts back to way too many lanes.

On reading this post it seems like some folks are not getting this problem. I’ve searched help files, preferences etc incase I’m missing some new setting that makes this happen - but to no avail.

Has anyone here yet figured how to fix this??

Please help

Ian H

Hello,


At the moment we could not reproduce this.

Please thrash the Cubase preferences (also from older Cubase versions). Do you still have this weird behaviour ? More details regarding thrashing the preferences can be found here https://www.steinberg.net/en/support/knowledgebase_new/show_details/kb_show/removing-the-preferences-of-the-sequencer.html

Cheers,

Chris

I thrashed the preferences, removing not just my Cubase 6 settings, but the settings of my previous version too. Unfortunately, it doesn’t make a difference. Any other thoughts? I should add that the project I’m working on was started some time ago – on Cubase 5 or earlier. I’m not sure if I would have this problem with a fresh project that was started with Cubase 6. I should also add, FWIW, that the same problem occurs using the 64 bit version of Cubase 6.

Thanks,

Alan

Many thanks to Chris Beuermann for looking into this issue. I have some more feedback which I hope will be of use…

I tried the dumping of preferences and it made no difference. However, I have done some diagnostics as logically as I can manage and can report the following…

It seems to be the case that the “extra/unwanted” lanes that mysteriously appear after I quit Cubase and then re-open a project only happens on tracks that have show-lanes enabled when I saved and quit. If I remember to hide the lanes on a track (or tracks) - then save and quit and re-open - then those tracks where the lanes were hidden DO NOT create the extra/unwanted lanes. The tracks that I left with show lanes enabled when I saved and quit are the ones that DO create the extra/unwanted lanes.

My challenge now is to remember to hide all the lanes on all the tracks before a save and quit. If I remember to do this then when I re-open the project and re-enable/show lanes everything appears as I want and expect!

QUESTION: Is there any way (as a temporary work-around) that some kind of macro could automatically be triggered when I close a project and/or quit Cubase that will hide all lanes? That way I don’t have to always remember to close them.

Some other info FWIW - as per what ADWalpert reports - the project I am working on began life in Cubase 5. I have not yet tested to see if the same unwanted lanes issue arises if I start a new project totally in Cubase 6.

Chris et al - I would be very grateful to receive any further suggestions regarding this issue. It is having a severely detrimental impact on my workflow (although now, as long as I remember to hide lanes on all tracks before saving and quiting, the situation has improved somewhat)!

Kind regards

Ian Haddow

Thanks, IanH, for the latest update. It’s nice to know that at least there’s a work-around for now, though I would hope that Steinberg will get to the real route of the problem and fix this bug.

I did some additional troubleshooting last week, and I discovered that even when I start a brand new project in Cubase 6, I still get lanes multiplying like rabbits – so it doesn’t seem to be a matter of having started the projects in earlier versions of Cubase.

Anyway, thanks again.

I am having this problem as well… huge numbers of lanes being created. I was working with about 7 takes to comp a part. I save the project… then reopen the project, and suddenly the project has about 40 lanes!!! It makes for a real mess from that point forward.

I am having a tough time adapting to this new comping system - the automatic cutting of all takes is really weird for me… also, the automatic muting - and now this massive lane multiplying. I seriously hope they offer a fix for this very soon. I miss the old way :frowning:

Can someone please post a .CPR file that exhibits the problem?

IanH, ADWolpert; Thanks for looking into this deeper and for the work-around!

Chris: Has this been noted as a bug by the Steinberg Dev team, or is more info needed?

Update: Not long after making my initial post my DAW suffered a complete meltdown (power supply malfunctioned and literally fried my motherboard and hard drives - OUCH! :cry: ). So now I’ve got a new i7 PC running Windows 7 64bit (was previously using Vista 64bit) and Cubase (6.02) is still adding the extra lanes as I (and several other users now) have described here (happens in both 32 and 64 bit versions).

FunkyDrummer: I’ve attached a .CPR file that exhibits this issue (same .CPR file that I used to test with in my initial post).

Johnny Z
Lane Test.cpr (96.3 KB)

Thanks for the test CPR.

Your scenario also highlights another lanes problem:

In the “lanes test.cpr” try to re-arrange events within the lanes, into a more “sensible” logical order. You will see that this causes much unwanted muting and unmuting of parts.

If you select an event via lasso, or holding down the shift key while selecting, then this bypasses the mute-on-selection that usually happens, but they will still mute/unmute once you actually drag and drop them somewhere :frowning:

So I would suggest that the muting/unmuting should not happen when dragging and dropping; only when you single click (and don’t drag it anywhere)

I can’t seem to find any see any workaround for this (?)

/FD

Hey FunkyDrummer et al

I read with interest the additional issue that arises when you try to drag events from one lane to another in order to put things back in a more “sensible” order after being hit by mysterious creation of many unwanted (and seemingly unnecessary lanes) issue. I too experienced this but I figured a work-around and would be happy to hear if this also works for you and others.

I have discovered that if there are multiple takes/events spanning a number of lanes and you click and drag an event to another lane then it becomes the active event as FunkyDrummer reports - even when you don’t want this. However, if I want to drag an event from one lane to another, and the the event in question is NOT currently the active event, if I use the mute tool first to click on it, then click and drag, it does NOT become the active event. This seems logical enough given the new Cubase 6 comping behaviour. However, what’s even more weird is that - on an event that is NOT the “active” but is not actually muted - if I mute the event using the mute tool, then immediately click on it again with the mute tool (effectively muting it then immediately un-muting it) then I can click and drag it from one lane to another WITHOUT it becoming the active event. In other words, the selection behaviour seems to be different for an event that has been muted then un-muted than it is for a non-active event that has never been muted/un-muted.

Another useful thing I have discovered to do with dragging events from one lane to another is as follows…

Initially I was perplexed by the new behaviour that means when you Cmd-click (on Mac OS X) on an event then it auditions the event. This is sometimes handy but caused me problems initially when compared to behaviour of Cmd-click and drag in Cubase 5 or earlier. I wanted to be able to click and drag from one lane too another and ensure that start/end time for event stayed exactly the same without auditioning the event. I discovered that I have to…

Click and hold on the event - then with mouse button still held - hold down the Cmd key (i think Cntrl on Windows?) - then drag the event to the required lane - it does what I want. In other words - I can drag the event and ensure I’m not moving start/end times and, as long as I have clicked-and-held before pressing Cmd, it does NOT audition. If I follow this procedure along with the technique of muting/unmuting events described above then things get a little closer to behaving how I want them to!!

It’s all a little tricky to describe so I hope the above makes sense and might be useful to others. It’s much quicker to do than to describe!

BTW - Thanks to Johnny Z for posting .CPR. I sincerely hope it helps Steinberg fix these troublesome issues.

Cheers

Ian H

Is anybody from Steinberg looking into this?

Not reproducible with Cubase 6.02

Gr,
JHP

Well I hope you keep looking, because we are not imagining this !!

Plus you can definitely repro the extra problem I outline above - dragging muted parts to another location within the lanes should NOT cause auto muting and unmuting! This is neither logical or useful ! (in fact it is very very unhelpful) Why on earth should moving a part affect it’s (and others) mute status) ??? It’s crazy!

First off, to address the OP: in your Test.cpr project, if i rearrange the events back to how you had them (i.e. Take 1 on Lane 1, etc) and Revert, then they go back to being split between lanes but this time with the focus on the last lane.

But I can’t repro with my test project, with or without lanes open on record (record settings: “Keep History”, Audio Pre-record=1s, Pre-roll OFF). C6.0.2 64-bit, Win7

[rest of this post was off-topic so I deleted it following mod’s request]