Strange Latency Problem

Hi there,

Ive been ahving this odd problem with significant latency when monitoring live sources in Cubase 6.02. Basically if I open up our template or. for that matter, just begin an empty project, I get bad latency when speaking thru the mic. This is independent of the buffer size I use - whether its 128 samples or 2048 it is the same. I am not using any plugins in the signal chain. The Mac is a beefy system as well.

We have an Apogee Ensemble. I thought initially it is a problem with the drivers. Ive updated them to the latest and there are no issues.

The strange thing is that if I go and change the buffer size to something else (doesnt matter what it is) the problem goes away and everything is fine. Or if I tell Cubase to use the internal sound card and then switch back to the ensemble everything is fine again. Both actions seem to “reset” things back to normal.

Ive checked the input/output routing - nothing wrong there. The thing is Ive also tested this in Ableton Live and I dont have ANY latency issues. Anyone else having these issues between the Ensemble and Cubase?? Please help.

OSX 10.6.8

I’m on PC and guess this shouldn’t be the same problem on Mac but here goes.
If this happens to me I go to Windows Sound Management (Sounds) and there find the recording/playback sample rates (typically the usual 44.1/16 or 48/16 etc). I found that just changing these values solved whatever glitch caused it and also they were fixed when I changed them back.?!
Hope it’s pretty similar for the Mac.

Conman - So you are running Win7 64bit, right? I am about ready to move up to Win7 64 so this is good to know.

And what you are saying is: If you choose 48Khz/24bit in C6, that sometimes (or just one time?) Win7 will not make the necessary adjustment and you need to go into Win7 to toggle it’s Khz/sampling rate to make Win7 recognize the commands you set in C6?

Is this what you are saying? If this is correct, do/did you experience what the original poster experienced? This is really interesting to me, thanks for your answer in advance.

I don’t exactly know what happened. I just lost sound (everywhere, not just Cubase) one time and, among other things, I went into the Windows Sounds and changed it from 44.1 (which I’d set it at) to 48 and all was back to normal. To check whether the effect was just involving the 44.1 setting I changed it back and it still worked.
I figure that somewhere I triggered a Windows bug. And I have had to do it one time since.
Over quite a few years I have found that jiggling the controls most likely to cause (any particular) glitches can, if you don’t go mad and spend days doing it, produce some surprising results.

W7 /64 should not be a problem for you but if any sound loss should happen then it’s a pointer. You should experience a “set and forget” easy transition with no problems.

Well its the same thing when i go and change the buffer size - example:

  • start at 384 samples. Weird Latency
  • switch to 256 samples. Works fine.
  • switch back to 384 samples. Still works fine.

As long as Cubase is open and I swicth to different projects everything is OK after doing this “reset”. But if I close Cubase and re-open the same problem comes back, regardless of what project Im loading. This does NOT happen in Ableton Live using the Ensemble.


EDIT: Also what happened to Steinberg Online Tech support?? We have one guy (yes one) at Yamaha in Australia who is our only contact in the entire country for tech support, and he’s nit in the office that much. :angry:

Ableton probably has a lot simpler routing system than Cubase but still…
Can you work at lower sample rates than 256. I typically work at 64 or 128 depending on the load. If I hear unwanted noise I’ll back off.
And, because I can’t tell from the description, you are using the right driver form inside Cubase’s Devices Setup? (under the Devices menu)
I don’t know if Ableton’s like Sonar but Sonar, at least one version, did it all for the user whereas Cubase doesn’t. Cubase just defaults to a Generic ASIO driver which does give awful latency.

Yes, Im using the right driver in Cubase and I can work at lower buffer sizes. Another way to fix the problem is to switch to the internal sound card and back again to the Ensemble. The latency has nothing to do with buffer sizes per se. Im talking about a latency of over a second here, regardless if the buffer size is 64 samples or 2048. Also Cubase is reporting the correct latencies for the buffer sizes, but it is not what I hear. As soon as I switch the buffer size though, everything is back to normal - it doesnt matter what I switch it to. It also happens whether it be a fully loaded template or a project with one track. Im not using any complex routing or plugins in the chain.

Thanks for that. Strange. Is there a latency checker for the Mac online as there is for PCs? These typically trouble-shoot any problems in the computer’s internal chain and pinpoint any delays at any given point.
To get support isn’t it possible where you are to email the support here: ?

I don’t think I can help further but I did expect a Mac user might turn up with a solution as problems like this usually have a simple, but hard to find, solution.

Interesting the problem does not occur when running Cubase in 32-bit mode. It must be some communication issue between the Ensemble and Cubase in the 64bit environment. Apogee support so far has been most unhelpful and have said they havent heard of such a problem. Anyone else out there with the same gear who can confirm this?