Strange layout behavior

Am I missing something really basic, or is the behavior in this video odd? I am trying to move a staff from page 2 to page 1 by selecting the first note of the part (on page 1) and the last note at the end of the system I want to move from page 2. I hit “make into frame”, and it moves the system up to page 1. However, it also breaks the first system into two systems. If I then try to recombine the first (now) two systems into what should be one system with “make into system”, the system at the bottom of the page I had just moved from page 2 to page 1 returns to page 2. If I then repeat the “make into frame” process, it again breaks the first system. It seems like this should be pretty simple, but I cannot understand what is going on here.

https://youtu.be/tTAO-SGXv9U

It’s because you can’t have both a system and a frame break at the same rhythmic position, IIRC. You need to remove the system break if you want to make into frame.

In general, it’s best to set your frame breaks first, then modify system breaks as needed.

But you’re fighting the program. You shouldn’t need system breaks on every line! Why not allow Dorico to adjust bars itself? Or if you want fixed casting off, you can set that in Layout Options–Staves and Systems–Casting Off, and set a fixed value.

Sorry, but I don’t think I follow. If I remove the system break, then I get about 12 measures on a single staff.

Here’s what I did originally:

  1. I selected the first note and the last note at the end of the first system of the second page. I chose “make into frame”.
  2. I then selected the first and last notes of the first 6 measures and chose “make into system”. It then shoots the last system off onto page 2 by itself.

The reason I have system breaks on every line in the video is because my second try was to lock in EVERY system in the hope that it would somehow stabilize the layout, which of course it didn’t.

In general, I like Dorico’s layout decisions. In this case, I have a third page with only two staves, and I simply want to reduce to two pages each with one additional staff.

I know it probably isn’t helpful to mention this, but in Finale I find this kind of adjustment pretty easy: just select all the systems and reduce the spacing between them. They all move up by the same amount, and then I can manually adjust each one a little bit. I am just not finding a way to settle in yet with Dorico’s method, both because I cannot seem to learn how consistently to get it to follow my frame/system breaks and also because I don’t see any way to adjust several systems at once. It’s a lot of manual dragging each system, if I can get them on the right pages. I’ve watched the videos and read the manual, but I don’t see any ways around this.

Thanks for your help!

Using “Make Into Frame” and “Make Into System” on overlapping material can get you into a real mess. The “Make Into Frame” button sets a Frame Break at the start of the selection, and a Frame Break just after the end of the selection, and enables the “Wait for next frame break” property for the first frame break (meaning that none of the music between the two frame breaks can drift onto another frame. It may be easier to set these options manually if you already have breaks within the selection.

Trying to get Dorico to mimic Finale is negating the strengths Dorico offers and is fighting the system.

I say this as someone who has used Finale since its original implementation and still uses it when I need capabilities Dorico does not yet offer.

JJM, here’s what you want to do:

  1. Delete all your system and frame breaks.
  2. Click on the first item in the bar, and Shift-F
  3. Click on the first item in the first bar of the second system on page 2, and Shift-F.
  4. Select the first Frame break (in bar 1) and toggle “Wait for next frame break.”
  5. Select the second frame break (which is now the beginning of page 2) and toggle that same option on.

I initially missed Finale’s functionality in this regard as well (select a bar and press up or down arrow). But I don’t any more. Now I vastly prefer Dorico’s handling of it. Just takes time to acclimate to something different!

This is extremely helpful! I didn’t quite understand how “wait for next frame break” worked until seeing this process laid out like this.

Now, the only thing I don’t get is: How do I then bump the first measure of the second system onto the first system without destroying the rest of the layout? If I select the first note and the last note of measure 6, and then hit “make into system” I get the same problem. There must be some other way to do this, since, as many have said, using frame and system breaks together causes issues.

Add a System Break at the start of bar 7. Set it to Wait for the next Frame Break. Then tell the Frame Break at bar 1 to wait for the next System Break.

OK, I get this, thank you. So it isn’t enough to simply move a group of measures into a single system–IF it’s the first system on a page. You then have to tell that newly created frame break (which also functions as a system break) to “wait for next system”. From that point, each addition system break that I create by selecting a range of measures/notes will automatically “wait for next system”. In some ways, this seems efficient, especially in cases where Dorico makes the same decisions that I might make in the measure layout. If I disagree significantly with the algorithms, it’s a little taxing but not too bad.

I can’t tell you how helpful this has been. Thank you all very much.

Breaks never automatically wait for the next break, unless you create them by using the “Make Into” buttons.

The thing that causes problems is using the “Make Into” buttons multiple times on the same music, because, as Dan said earlier, you can’t have a Frame Break and a System Break at the same location. If you use “Make Into Frame” then the Frame Break at bar 1 is set to wait for the next Frame break. If you then use “Make Into System” then you might find that the Frame Break at bar 1 gets replaced by a System Break, or you might find that it remains a Frame Break, has “wait for next System break” set but ends up with “wait for next Frame break” unset.

Basically, the new properties aren’t added to the existing ones; they replace the existing ones.

This is why I much preferred the old solution: Frame Breaks and System Breaks (with “wait for next” properties), and no “Make Into” buttons. Under that system we users were forced to understand how the thing works! Now, it’s quite easy to use the “Make Into” buttons with signposts turned off, and not understand what’s going on behind the scenes (and why it doesn’t necessarily seem to work logically).