Strange MIDI input problem

C7.5.2. There is no midi input for the notes Bb3-C4. These notes can be played on the key editor keyboard, but when played from an external keyboard, the midi activity indicator shows no input. I’ve tried two different keyboards with the same result. I can perform this experiment in Logic Pro and the notes will play.

Are you using an 88 note keyboard, a 76 or 61 key one?

Reason is, on my 61 key, there are octave buttons that will influence what notes will be sent depending on where the keys are pressed on it - and where those octave buttons settings currently are.

Thanks but I don’t think anything like this could be the problem. The note keys on my M-Audio 25 can be set to functions other than midi notes. However, the other keyboard I used, an old Roland JV-30 synth, doesn’t use keys to send messages. Also if the keyboard were the issue the same problem should occur when I use Logic.

Have you done the basic troubleshooting steps of checking this in an empty project with initialized prefs?


I’ve also now done this test with C6.5 and C7 and cannot recreate the problem. This would seem to point to the C7.5 preferences, but I did reset them to the default preferences (which I have not changed), and doing this did not correct the problem.

One of the factoid about this problem: The transport bar is showing midi input for these three notes, but the track meter is not.


Just a guess.

Good guess, but no, the input transformer was not activated.

Possibly an Expression Map active on the track then?

Also a good guess, but I’ve already checked for an active expression map.

You gotta be kidding. Well, why don’t you simply list the stuff you have eliminated already, so we can stop playing games.

Actually, the only things that I have thought of are the ones that have been mentioned here, namely:

Logical Transformer
Expression Maps

And to summarize what I’ve said before, the problem does not occur in:

Logic Pro X

The problem does occur in C7.5 in a new project with the preferences set to default.

Are those notes active for the VST Quick Controls, in your Devices Setup? Unlike for Track Quick Controls, any MIDI input that is used there takes precedence over the “regular” MIDI inputs.

Are those notes active for the VST Quick Controls, in your Devices Setup?

Ooooh. Good one, Vic. I’ll bet a buck that’s it.

I was about to say the same thing…

(I have definitely become more grumpy lately. I’ll try to be nicer :blush: )

The quick controls were the problem. I needed a piano to test a melody so I used one from Halion Sonic. Somehow the quick controls for the piano got assigned. I certainly didn’t do it consciously. I don’t know how.

Thanks, vic, for you help. Now that I know you’re in the new forum I figure I can also get intelligent answers to some of the score editor questions I seem to run into.