Strange record behavior with Xtouch compact

Using the transport controls on my X-Touch Compact, the record button works fine except that it overwrites the previous two bars. For example, to get the result in the image below I start with a completely blank track, put the cursor on bar 2, press the transport record button on the xtouch, record 3 notes and hit stop on the Xtouch. That’s it. You can see that it would have overwrote anything on bars 0 and 1. Any idea what would cause this?

Looks like it may have something to do with the metronome count-in. If I have the count-in turned on and set to 1 bar, hitting record on the Xtouch overwrites the previous 2 bars. If count-in is set to 2 bars, it overwrites the previous 3 bars. Set to 3, overwrites previous 4 bars, etc…

If the count-in is disabled it works just fine. Also works fine using keyboard controls, regardless of the count-in setting (ie. * key for record, etc.). So it seems that it’s only an issue with the Xtouch and when using the metronome count-in.


I don’t think this is Xtouch related. I expect it works the very same way, if you start the Record (and the Count-In is enabled) from the Transport Panel.

It definitely does not happen when using the Transport panel or shortcut keys on the keyboard. But even if it did, is there a setting or preference in Cubase that would cause this?

After further review, it seems the cc113 and cc114 are being written to the track which Cubase seems to be treating as note data. The only way to avoid this is to either not use the count-in or use the Merge record mode. Or is there a way to configure the Xtouch? Or suppress the data in Cubase from not being written to the track?


Disable your Xtouch from the All MIDI Inputs in the Studio Setup, please.


Thank you Martin. In Studio Setup I selected MIDI Port Setup and unchecked the Active box for “In 'All Midi”. That worked!

The other solution I found that worked is to go to Edit > Preferences > Midi > Midi Filter, and add values for CC113 and CC114 in the Controller section.

Thanks for your help on this!


This is not good solution. Anything (but MIDI CC113 & CC114 you filtered out) you would touch on the Xtoch while recording would be recorded to the MIDI track.

If I disable the midi input it solves the CC113 problem but then the faders don’t work for CC1 and CC11. But if I just filter out CC113 and CC114 in Midi filter preferences it seems everything works fine.


Do you use the Xtouch as a DAW controller or as a MIDI controller, please?

Well, I guess that’s a good question. If I’m trying to use both the transport controls and the faders to control CCs then I guess it’s both? Seems to be working fine if I filter out specific CC data.


I see. Now it makes sense.