Strange result when recording in a loop one midi and 3 audio tracks

Hello,

Cubase 12 Pro / W11 here.
Curiously the first lane (numbered 2 due to existing previous lane) of midi track does not start at the same bar and before the loop start ??? Next lanes were ok ???

Any idea on the reason for this ? Bug ?

Hi,

Did you use Count-in by any chance?

1 Like

Yes one bar ? Is it the reason ? I do not understand and need more explanations ?

Count-in is supposed to click the metronome for the specified duration before it starts playing/recording, so normally it doesn’t record anything during that time.

The image just looks like you simply had your Cursor to the left of the Cycle range and started recording from here.

Hi,

Agree.

Then even the Audio Event would start the bar ahead. I expect the Audio track above the MIDI one is the one, recorded simultaneously.

1 Like

Maybe this is due to certain combination of record modes + pre-roll and other settings, I don’t know what to say :confused:

But most importantly, is that reproducible ?

1 Like

No I press 1 before * each time and can repro.

Alright, this definitely looks like a bug with Count-in, or maybe this is intended but that looks very odd.

When Count-in is enabled and you hit Record, without inputting any key, the MIDI track will only turn red and start creating a new Part only when the Count-in ends. That’s the intended behavior.

However, if you input any MIDI note during the Count-in, then it will automatically create a Part and start recording notes in it, starting from the beginning of the Count-in duration. This is really weird as the Cursor isn’t even moving but still the notes get recorded, and even weirder, when you hold a note, it will be displayed as an endless note until you release it or press another :

midi count in issue

@Martin.Jirsak What do you think ? Should this be tagged as an issue ?

1 Like

Hi,

How is your Preferences > Record > MIDI > MIDI Record Catch Range settings, please?

It’s the default 100 ms.

MIDI Record Catch Range in ms
Ensures that the very start of a recording that starts at the left locator is included.

From what I understand it’s only a safety feature, if you hit a note slightly before the recording starts it gets included into the recording, but it only ranges up to 300 ms, so why would it enlarge the Part by several bars ? I have tried both 0 and 300 ms but I see no difference, it doesn’t seem to do anything. Maybe that’s what is actually bugged ?

1 Like

Edit : MIDI Record Catch Range is only for Cycle recording, the user manual description is totaly confusing and makes no sense, in reality it is for when you press a note very close the the Right Locator (within the set range), it will write the note at the start of the loop instead.
The description seriously needs to be edited to match exactly what it actually does.
This feature isn’t involved with Count-in at all.

So it’s a bug ?

It looks a little weird, but it’s not a bug. Cubase has always done this for MIDI tracks when Count-in is enabled (since Cubase SX at least).

This setting does indeed not apply to Count-in recording. It applies to Punch In recording, hence the reference to the left locator. Cycle recording works by automatically punching in and punching out with each cycle.

2 Likes

And why is it doing this ?
Is there any interest ?

1 Like

@Romantique_Tp Now that makes sense, thank you very much for the input ! But still I wonder why this isn’t referenced anywhere in the manual, there’s no clue about the circumstances in which MIDI Record Catch Range should apply.

About the count-in thing :
I share the same opinion as @csurieux , if the user wants to start recording a bit earlier, then they simply put the cursor accordingly, same as when recording audio.
I don’t see any use case of this “feature” (I mean the ability to input notes during the count-in), it means that we are always forced to resize/cleanup the Parts afterwards, it’s kind of a design flaw here.
It we put the cursor at a specific place it’s surely because we want to start recording from this exact place.

I understand that it does that in order to not miss the notes in the case we play slightly before the click, but then it should be based on the MIDI Record Catch Range setting, just like it does with Cycle Record, Punch in, and Pre-Roll.

And speaking of which, Pre-Roll and Count-in is basically the same thing :
Pre-Roll playbacks the actual project, while Count-in only clicks the metronome (it’s one or the other, we cannot use both at the same time), but in both cases, the recording is supposed to start where the Cursor was at the moment we pressed the Record button. At least, this is how Pre-Roll works, as it doesn’t allow to record within the Pre-Roll duration, but instead works in conjunction with MIDI Record Catch Range, only the notes that are played a bit early will snap to the start of the recording so they aren’t missed.

Why shouldn’t Count-in behave like that too ?
The way it behaves compared to Pre-Roll is quite illogical to me, it could make use of the catch range setting but instead it does some old-school stuff.
:face_with_raised_eyebrow:

1 Like