Strange stereo behavior Noteperformer

Good night, Dorico-ers compañeros. I want to ask something, please:

I do my first steps using Dorico and have Noteperformer installed and working. When I try simple lines, for example, with strings, they are played right most of the time, but sometimes a single note sounds weird: tuned, but with a stereo effect, for example I see that for violin 1 with notes like D5 and above it. But it happens sometimes and sometimes not. It is very distracting and it doesn’t sound good. Is someone having this problem? I attach a very simple project, where I have this in violin 1 and cello. In cello in solo doesn’t happen offen, but with all strings it appears. In violin 1 it happens sometimes in the first D5, and very offen in the second D5.

I use Windows 10 and have fllowed all steps listed in the Noteperformer manual to set it up for Dorico (default playback template, note durations). Map version is 12.

Thank you.
190627muestra.zip (449 KB)

I have generated an audio with violin 1 of the previous project in solo where this problem arises. It is kind of random, I tried several times exporting a mp3 to achieve a file showing the problem. By playing within Dorico the problem arises offener.

The first note (an 8th note D5 with tremolo) and the eighth one (a 4th note D5 in staccato) sound with a more pronounced stereo than the rest, with the stereo light delayed. Does someone of you observed (heard) that? I dont’t know how to avoid it. I believe the second note has that too.

Violin 2 has never this problem.

Thank you.

Edit: weird: if I put the maximizer inserted in the Master, but with 25% Optimize instead of 40% (as stated here https://www.steinberg.net/forums/viewtopic.php?p=868010#p868010), the notes with the problem are now from B5 and above. With Optimize in 40% is again from D5 the problem.
audio.zip (155 KB)

This is beyond my knowledge, I’m afraid, Knopf. Do you get the same pronounced stereo effect if you play back your music with the default ‘HSSE+HSO (Pro)’ playback template?

It’s interesting that changing the setting on the Maximizer plugin gave a different symptom. I never ran NotePerformer with either the Maximizer or Limiter plugins, but I’ve occasionally run into something that seemed kind of similar …

For me it didn’t usually happen during normal playback, but happened quite frequently when stopping playback mid-phrase, during the 1-second lag the look-ahead function necessitates. Sometimes when stopping playback mid-phrase, either of these would occur:

  1. a note would abruptly jump significantly in volume somewhere in the middle of its duration, or
  2. the audio modeling would suddenly change mid-note (for instance, strings marked “con sordino” would suddenly become “senza sordino” in the middle of the note, before playback stopped completely)

What I describe in #1 sounded most similar to the first note in your example, but not the eighth note.

I think I read somewhere that every sound in NotePerformer is modeled with DSP, so (just armchair speculation) #2 might be a result of some parts of the application receiving the “stop playback” command before other parts do. Maybe instructions are processed in a sequence, rather than in a brickwall “MIDI panic” kind of way.*

Don’t know if any of that is at all relevant to your issue, but it may be a contributing factor? This is certainly an intriguing thread; I’m curious to hear what you learn about this in the future!

*p.s. (Not everyone considers it a “feature,” but this was something I actually really liked about NotePerformer. Stopping playback mid-score, with instruments cutting out at slightly different times, felt a lot like conducting a high school orchestra where not everyone is paying equal attention to the baton :smiley: )

Oh, just thought of something … are your articulations all switching with 100% normal notation, or have you had to enter a redundant “nat” or “ord” anywhere? A redundant “nat” would be the only way I could see what I described in #2 being related to your issue.

Again, I find this fascinating and am interested to hear what you learn.

There is something weird here in the Dorico project, but I’ve no idea what it is.

I have NP, and it is my default playback template. When I open the attached project in Dorico it appears to load NP correctly, but the Violin 1 part doesn’t play at all for me. The other two string parts do play. I tried adding some more notes to Violin 1, and they didn’t play either during note entry or afterwards.

I reloaded the playback template (Version 12) and Violin 1 then played back as expected.

Also, I can’t see (with an audio editor) or hear the “weird stereo” effect in your mp3 file. Violin 1 is panned a long way to the left, which is consistent with the NP mixer, but I can’t find anything more than that. Playing the left and right channels separately doesn’t reveal anything to my ears.

The staves were solo’ed in the mixer, except violin 1… Hence the silence. Otherwise this file behaved normally here… :open_mouth:

Hah! I looked at the mixer, but didn’t notice that!

Good afternoon:

I wish you a pleasant musical Sunday. First I want to thank you Daniel, Samreed, Rob and fratveno for taking the time to throw and eye into this. Yes, I am sorry for the muted violin 1 in mixer, I was sure all strings were on but I missed the v1.

Daniel: with HSO I did not had the issue. Samreed, unfortunately I am amateur enough to don’t know what “nat” or “ord” are, so I can’t answer you.

But I can say following: when Rob said “Violin 1 is panned a long way to the left” it caught my attention, because I couldn’t hear V1 so long way to the left. To be honest, it sounded at center, though the default panning is L32. By doing more tests I could find that by panning far right or far left I heard no change. So I thought my issue was that I had not stereo at all, and these weird notes were maybe just intents from NP to make some notes sound where they should be. So this weird stero was maybe correct stereo and for the remaining notes I had just mono. I work in this moment with the internal sound of my notebook, as my interface and home studio are in another room, so I tried following: I noted that, when I change sample frequency from 48 kHz to 44 kHz in the device properties in Windows I heard the test sound in stereo. So I changed this frequency in Dorico too. Later I changed the driver from “generic low latency ASIO” to “ASIO directX full duplex”. Now I can hear the NP instruments in correct stereo, I hear the change when I change the panning and the over described issue is gone (for the moment). I can add here that, when I make a tremolo with two notes the issue was there, too, but not anymore. So, in summary, it was apparently a problem with my system sound settings (with HSO I could hear in stereo without this changes, though).

nat. = “natural”
ord. = “ordinary”

Basically it is a way to tell an instrument to return to its normal playing technique (as opposed to “Solo” or other techniques you may have applied).

Thank you, Derrek.

Technically “nat.” and “ord.” are abbreviations for the Italian words “naturale” and “ordinario”, but of course the English equivalents “natural” and “ordinary” work just as well.