Strange Timing Issue

Has anyone experienced strange behavior playing MIDI into Cubase

I have recently purchased a Focusrite PRO24 dsp, and this could be the issue

I’m having notes seem to record earlier than I played them in?

Im hardly a concert pianist but I know when my timings off and when its not, and Im always behind the beat if anything, not in front?

Its also making Quantise perform badly is quantise is moving things even further back in time (if you get what I mean)

Latency has always led to notes being recorded late (which Im used to), but now I’m getting them early Weird

Can anyone offer anything that may explain this (except - ‘yeah your playing is obviously shocking’) :wink:

See MIDI Timing in sig.


I will try this

seems odd to me, I have gone from a

USB2 interface to a Firewire, but all the latest drivers are installed.

I think I will also post on Focusrite forums, some users may have experienced similar.

Another question

My control Keyboard is MIDI.

If my control keyboard used USB, is this likely to get rid of the problem? As I only use softsynths and VST instruments/effects

Hi Betamac,

Did you ever resolve your timing issues?

I have the same problem and am slowly running out of patience with the lack of Steinberg support.


Please read the manual. This problem should not be there for anyone as of a few years ago.
Or get in touch with the SOUNDCARD support.
Have you actually politely contacted Steinberg support? Or do you just moan here?
12 posts. …slowly running out of patience? Do you know what that looks like?

Just think, in the time it took you to register and post your question, you could have looked on the next couple of pages of this forum or RTFM and found out the answer for yourself. > :wink:

I used to have a bunch of useful links here, but nobody ever seemed to look and demanded spoon feeding so why bother? > :wink:

:mrgreen: :mrgreen: :mrgreen: Kids are like that. :laughing:
Christmas getting to you bud? Happy new year.

Nope, just rude-a55 newbs. :wink: :laughing:


I have tried Mashedmitten’s suggestion as per the MIDI help pages on Steinberg, have noticed no difference in behavior, problem I’m having is.

  1. notes recording earlier than played and 2. this affecting quantise and causing further timing problems

I’m still trying to get it solved, but the behavior has occured since I changed from an Edirol UA-25 soundcard (using USB2), to a Focusrite PRO24 DSP (using Firewire). I’m not blaming Cubase (its more likely that The Focusrite Soundcard is the culprit) I just want to see if anyone’s had this, and what to do, if they know, while I’m trying to solve it myself and RTFM, no harm in that is there? :unamused:

The focusrite website suggest if there are problems to use a legacy driver which I will try, but wanted to update the thread.

still asking if anyone knows - If I had a seperate control Keyboard interface which used USB could this perhaps solve things as I use only VST synths, and therefore would not be reliant on MIDI?

(update) - just checked the Focusrite web - windows 7 - compatible - so I’m using the latest driver, and Focusrite claim this is compatible (with windows 7 64bit at least)

I think you’ll find in Devices Setup “use system timestamp” will fix this. And I hope I’ve saved you a day or so searching the manual for it.
Also google a latency checker which will highlight any problems in your system.
Remarks not aimed at you.

Thanks Conman

Did try the system Timestamp, it made no difference

Have ran the Latency checker and get good scores, so no probs there

I might power down and plug my Card into the Firewire socket that is on my motherboard, instead of the one I bought that has the Texas instruments chipset (as per what I was advised would work best)

never know this might be causing problems? prepared to have a go at anything :wink:

Follow the opposite advice from that link re: emulated ports.

If my control keyboard used USB, is this likely to get rid of the problem?

If it did, it would only be because the class compliant interface driver worked better than Focusrite’s. Keyboards with USB are just MIDI keyboards witha built in class compliant 1x1 USB midi interface.

Want to fix the problem? Get a MOTU MIDI interface. I had continuous problems with Cubase and previously Nuendo’s midi timing with RME HDSP MIDI, MIDIman 2x2 USB…an old SBLive card actually did better than those, FWIW…switched to a MOTU Parallel port MTPAV, and came back to Cubase (4 at the time) after years of swearing it off for the problems–problems went away. At some point, I switched to a MOTU USB 5x5, which has had solid internal and external timing. Was it fixed with C4 (and now C6)? Or MOTU’s driver/hardware? Who knows…call me superstitious, but when I read about someone having midi timing issues with modern Cubase, I’ve got to believe it’s the MOTU gear.

Beg or borrow a MOTU unit from your local dealer. If it fixes it, buy it and call it a day. If it doesn’t, you know the problem runs deeper–install Cubase on another computer. I’ve now had C4 or C6 on several different boxes with the MOTU hardware–both Mac and PC, XP and Win7x64…no midi timing problems (except the timing issues inherent to MIDI to begin with).

Just found an article on the Focusrite Website.

relating to pci express latency - I’m plugged into a PCI express Firewire card, so gonna revert back to the Firewire thats on my Motherboard see if it fixes it, but focusrite say that the texas instruments chipset (that im currently plugged to via PCI express) is the most reliable

popman - I cant really change to a different soundcard to fix this, I’ll lose money selling what I have, then lose again purchasing new.

How much is the Motu you suggest BTW

Right All

I have now tried bith fix options on Steinberg MIDI and Windows - disabled the filter and then tried each configuaration, and used the system timestamp.

have plugged to a different Firewire

nothing changes the problem

Have emailed Focusrite about this. Theres one thing to try yet, going on to a legacy driver (even though the driver I’m using is the latest and stated to be compatible with W7)

After that Im stuck

If I cant fix this would a seperate midi interface via USB (avail for £30) be an option

cos I didn’t have this problem before using my EDIROL UA25 (but it only had 2 inputs, 2 outputs thats why I upgraded …upgrade lol)

New year greetings. It looks now as if your best option at the moment is to continue contacting support of both your Soundcard and Steinberg.
You could also look at something like the Sound on Sound forums to see if you can get an overview of the problem as you can get quite cloistered in the Cubase forum and end up just getting one-line comments that don’t really help.

One you got the Emulated Ports to show, did you select it as the input of the track?


So I fired up a demo of Propellerhead Reason 6.0.1 That I have sitting on my system. Wanted to see if I get the same problem

And loaded a Piano, and set the click on, and rolled a few bars, played in a sequence of notes, then played it back and it sounded exactly as it should.

I have also loaded up a Cubase template ‘electro production’ , set it into record, played a riff on a track that was set up and it behaved itself. Then randomly picked a finished project, loaded it, picked a spot on a track that was clear, played a riff, same timing problems…Does this mean its worse when the system has more to cope with?

This is weird

Mashedmitten - will try this to make sure


Under device set-up have you enabled “direct monitoring”? I solved my problem by enabling this and then ticking the “time strap” box.

A quick note to whoever added the little bit of sarcasm to one of my posts. I am moaning on here because my last two “Support Requests” have never been answered! The last time I spent money phoning Germany was to find out that there was no differential between zero’s and capital 0’s on an activation code. :angry: