Strange Unmix behavior SL 10 ARA within Cubase 13

After unmixing and dragging the unmixed events into the Cubase timeline (No info on the proper way to do this), various strange bugs occurred.
The ARA icon remained on the dragged / exported tracks even though those unmixed tracks did not have spectralayers on them (only on the source song track for unmixing).
Any editing of these events caused crashes and/or big sync issues between the audio playback and the event position.
“Make ext. permananent” on the source song track makes the event silent.
Strange workaround was to press delete on the exported events which removed the ARA icon rather than delete the event.
Images below


After pressing delete on events:

1 Like

And it gets stranger…

If the first exported track is muted or deleted it still plays and is out of sync with the song. I cannot make extension permanent on the source without causing a silent source song event (not the end of the world as it’s served it’s purpose, but weird).

I imagine it would be better to do the audio unmixing in the standalone version and export the wavs…

1 Like

From memory I encountered something very similar to this. I seem to recall that once I had dragged the tracks from spectral layers to the arrangement window I had to click remove extension twice on each track (the first click seemed to do nothing) and then the ARA extension went away and everything behaved as expected.

1 Like

In my case, despite the ARA icon on those tracks, there was no extension option on each track to remove. I literally tried to delete the event, then the ARA icon disappeared.

@garethk what version of Cubase and SpectraLayers ? What OS ?

… yes, that would be good to know. And do you a small description how we can reproduce it? I see that you track “World on Fire (R)” has loaded SpectraLayers as an ARA Plug-In on “Track Level”. There, you you have your source audio file. Then let’s say …

  1. Start Cubase
  2. Add an audio track
  3. Load SpectraLayers on Track Level (Inspector)
  4. Add an audio file
  5. Unmix the audio file

… and now? Every hint or example project would help.

Thank you,
Michael.

Cubase 13 & SL10 as it says in the topic tile. Specifically 13.0.10 (not quite the latest)
and SL10.0.40 .

Update, I’ve just read the release notes for 13.0.20 and seen there was an ARA bugfix related to this issue. Will update now. Thanks.

Hi,

If I get your case right, I can reproduce the following:

  • New Cubase project
  • import Stereo audio file
  • Select the event and apply SL extension
  • Run unmix (in my case vocal, bass, drums, other)
  • Set cursor at 0 (begining of the project)
  • Drag/Drop the 5 Layers in the project (vocal, bass, drums, other, non-unmixed), one by one.

=> new tracks are created from the drag and drop. The created events do have the SL extensions (like in your picture). New layer are created in SL (named with the addition of a 10 digit number).

  • Select the “source” audio event (the one imported in step 2), and apply “make the extension permanent”.
  • The audio file becomes silent/empty.

I run the latest C13/SL10 versions, on W10 with a 4060Ti.

Later, I tried with just importing only 1 layer into C13, and it worked as expected. So it may have to do with the number of layers you are importing. I’ll try to do more tests later today.

It was a bug that’s been repaired in .0.21.