Strange Value Numbers

When I enter 0, I get -0.03 or a value of 2 I get 1.97.

Looks like I’m not getting integer numbers. Does anyone know how to fix this?

Reboot? Different project?

I’ve tried rebooting and this also happens on an empty project.

Also the other thing I’ve noticed is that my Pan is set to L2 instead of Center. Something very strange is happening.

Reset Preferences or I’m out of ideas.

Exactly the same problem I have. https://www.steinberg.net/forums/viewtopic.php?f=286&t=191716.

So I figured out what is is for me. Not sure if it’s the same issue for you @ThSve.

Looks like it’s a Metagrid XML file, but specifically the one named “Metasystem3.xml”. It has to do with the Volume, Pan and Volume Reset. If you delete the generic remote linked to this one then it will make your numbers go back to Integers again. Not sure if someone can help with the specific script to fix it?

If running a generic remote, and the faders are assigned to a continuous controller, and there is a back and forth communication between Cubase and the controller:

You put the fader to 0, then cubase sends it through midi out to the controller as a value between 0-127. Then the controller fader updates its position, and informs Cubase sending the value back. This value between 0-127 is too coarse to represent your actual 0. The nearest value is 0.03.

The same with pan. If you must find the center and you have only 0-127 to express it, the center is at 63,5. But, we must use only natural numbers, so we get either 63, or 64. Which is just left or right of the center.

All of the above are presented very crudely, with no regards to accuracy and terminology, but that’s sort of what happens. I tried to make “high resolution” faders for my generic remotes (that wouldn’t suffer from this problem), but it was wayyyy over my head.

Thanks for the detailed response. The weird thing is that I’ve used Metagrid for a while and have never had this issue before until recently and I’m sure other users that use Metagrid would have also had this issue unless it just doesn’t bug them enough :smiley:

Well, it depends on how Metagrid communicates with Cubase.

Unfortunately, I don’t know anything about Metagrid (since I don’t own a single iOS device), except that it’s VERY VERY good. I know it can send key commands from buttons, and it’s also got MIDI.

I use TouchPortal for sending keystrokes. I can control the volume faders and pan pots with buttons using the keycommands Primary Parameter: Increase/Decrease, and Fine Increase/Decrease. That doesn’t involve MIDI and no weird numbers show up.

With MIDI, I’ve tried touchOSC, which communicates back and forth with Cubase, and in this case I get the weird numbers. I could try and use NRPN to have greater resolution and solve the problem, but as I said… way over my head!