Strange VST Plugins corruption

I have windows 7 64-bit.

Yesterday I got a BSOD while loading a project. Afterwards opening the project resulted in a crash. In fact, even loading an older version of the project made Cubase 5 64-bit crash. Now it seems that even though I initialize my preferences, Cubase for some reason still remembers the VST folder location.

So yeah, removed Cubase, initialized preferences, also tried different combinations, like renaming Cubase Prefs but not VST folder, the other way around and so forth. Nothing works. Everytime I open Cubase it remembers the old path for the VST2 plugins. I did manage to get the project open by removing the faulty plugins. However, every time Cubase starts it still loads the old plugin paths.

I thought at the very least I would like to open the project without the plugins and just continue from there. However, now it seems I can’t even start a new project and get my plugins to work, or even make sense of what it is that Cubase is trying to load. Why does Cubase load the old, crashed location for the VST plugins even after initializing and re-installing?

I am kind of lost, I don’t really know what I’m doing at this point anymore.

I would hope to get Cubase to at least open without these problems, and hopefully then be able to reopen the project. But I don’t know what to do next.



VST 2x Plug-in Paths shows:
C:\Program Files\Common Files\Steinberg\VST2

Both of these locations are visible every time I start. Removing “D:\JBridgeVST-Plugins” from the list with the remove button, removes it from the list. However, updating by pressing “Update” does NOT remove the plugins from the list after removing the folder from the locational tree, nor does pressing “Update Plug-in information”. Next time I start Cubase, the path “D:\JBridgeVST-Plugins” will have returned.

I got the plugin folder not to load. Embarrassingly, it was a screwup on my part I think. I had the folder set to shared folder. Changing the shared folder to “C:\Program Files\Common Files\Steinberg\VST2” solved the problem. But now I cannot load fresh instances of the plugins in a different directory without Cubase crashing.
I tried making new bridged .dll’s with JBridge from the original 32-bit files, and it reports a problem with “auxhost”. It’s in finnish and I will try to translate it later but now I gotta go for now.

If you read all this, thanks ^^

I got JBridge working now. Now a strange thing happened, which perhaps might make some of you who actually know what you are doing, be able to pinpoint the problem. I loaded some VST’s succesfully, but now I tried to load my CamelPhat plugin, from a new location, and Cubase says: Unkown architecture or file not found (Is D:\VSTx32-Plugins…CamelPhat3.dll the correct path? ), which is the wrong address, not specified by me. Yet the plugin list shows it’s correct location. Upon loading the plugin into an insert Cubase gives me the same error.