Struggling to speed up project

Hi All, Im using Cubase 10 Pro. I have a terrible habit of nearly finishing a project then realising it needs to be a bit faster. So I raise the tempo by 10BPM. The audio is all over the place so I highlight one full audio track at a time. I go to Audio / Processes / Time Stretch. I choose original bpm on the left and enter new bpm on the right. I apply and repeat for each audio track. The end result is all over the place. Can someone tell me what I am doing wrong please? Thanks for your help

At original tempo, open the pool and enable musical mode for all the audio and enter the original tempo, it allows multiple selections so you can enter them all at once.
After you’ve done this make sure none of the audio track’s time base is set to timecode i.e. set all to musical timebase. If all are set, you can then change tempo freely to any value in realtime.

Fantastic thank you very much!