Strum GS crashes VSTAudioEngine

I ran into an issue where adding a VST plugin from AAS, Strum-GS 2, to Dorico results in a crash and the message to restart the VSTAudioEngine after saving under a different name.
The plugin itself works in Cubase. It also seems like other AAS plugins (Strum Session and Ultra Analog session tested) crash Dorico.

I think I used that plugin in an older version,
but I can’t remember which project that was.

Attached is a crashdump after loading Strum-GS 2.
Dorico 4 AudioEngine 64bit 2022.5.28 21.25.dmp (715.0 KB)

Edit: I found that old project. I indeed used Strum-GS 2. The project worked with version 3.1. Opening it in 4 and playback work. The project seems to be more prone to crashes, though.
I also tried to load the plugin in different new projects with no success - immediately got the error.

Hi @SebKaep , welcome to the forum.

Thanks for reporting this. I will have a look at the crash dump on Monday, so a little patience, please.

Hi @SebKaep , the crash is in the audio engine itself and the stack trace shows a pattern I’ve never seen before, so this is a completely new issue.

What I can’t see from the dump file, which version of Strum you have and if you are using the VST2 or VST3 variant.

I downloaded the trial version of Strum GS 2 ( and that one works well for me, both VST2 and VST3, but I did not give it a hard go. Could you please provide me with your project? If it is confidential, please send directly to u dot stoermer at steinberg dot de. Thanks

Hello @Ulf , thanks for your fast replies. You made me think about VST version. It should have been VST3, but more important, I updated Strum GS 2 to the latest version (have been on 2.2.2), and it didn’t crash so far. I just didn’t think of a problem in the VST since it worked before with older versions of Dorico.

I will play around and test it more today, but it seems like the issue is solved with the plugin update.
I will report back how it goes and may test my other plugins from AAS, too.

So far, thank you for your help.

1 Like

Hello @Ulf,
I completed the project yesterday. Strum GS 2 was working perfectly fine, no issues or crashes within around 2 hours of work. I’d consider this solved. If you still want to look at my project to track down that issue, I could send it, though.

Again thank you very much for your effort!

Hi @SebKaep , you are more than welcome.
If it is working now for you, then let’s rest the case. But should you get trouble again, don’t hesitate to come back and I’ll have a look again.