Stuck on eLicenser is depracated problem

I have Cubase 10 LE installed on a Windows 10 PC, which I recently upgraded - but kept using the same win10 boot hard drive.

Ever since the upgrade, my eLicenser stopped working, and I cannot find a solution to the problem.
I tried to launch Cubase but it generated an error about the license, so I reinstalled eLicenser and Cubase as well, then tried to reactivate the app on MySteinberg, but I got an error message “This eLicenser is deprecated”.

I have a MacBook laptop with Cubase Elements 10.5, so I transferred the 10 LE license to its eLicenser, and that worked.

I then followed the instructions on this page step by step, and tried to reactivate again, but the problem persists - same message: “This eLicenser is deprecated”.

The support company in my country (Israel) does not provide support for LE versions and won’t help, and I’m stuck without Cubase working on my PC, which is my recording computer.

I’d appreciate any help in this!

Hi and welcome,

Get in contact with official Steinberg support, please.

Martin, as I wrote above, I did not have that option (that was one of the first things I tried).

The only thing that worked, eventually, by the way is running the elc-installation-helper.exe that can be found here:
https://helpcenter.steinberg.de/hc/en-us/articles/206632670-Soft-eLicenser-virtual-license-container-is-missing

I went through pretty much hell and a whole reinstallation of Windows to try to fix this, while this simple fix could probably solve this problem from the get-go. But the documentation on Steinberg’s website and online generally is VERY unhelpful and I stumbled on this solution by chance, gladly.

I have to say that eLicenser and the entire stack of licensing for Cubase is without a doubt the worst and most frustrating I’ve ever encountered in over 30 years of working with software (and developing quite a bit of software myself).

I hope this could be helpful for other people who might run into this problem.

1 Like