Stumped by Generic Controller setup

I’m trying to get a simple MIDI controller transmitting CC7 to control the master fader in Nuendo.

I created a Generic Controller in Studio Setup,

(Fader 9 is the master fader)

Can you see why this wouldn’t work?

I CAN get Fader 9 to control the master fader if I use the Track Quick Controls, but in that mode the link only works if the Master channel is selected in Nuendo - I need it to work all the time


Don’t you need to assign the midi output, some flags, etc?

Thanks - I tried that - all combinations… none made any difference, same with MIDI output - I figured since the controller is routed to Nuendo’s mixer I wouldn’t need to allocate a MIDI output. But as I say, makes no difference

I just recreated what you are doing with a nanoKontrol2 and it works fine. However, I did do a midi learn on fader 9, just to make sure my nano fader was translating properly.

Yes, tried that too - it does ‘learn’ the expected numbers. It’s weird that putting the same setup into Track Quick Controls does work. Is there a way to get the Track quick controls to stay working if the output channel isn’t highlighted?

Fader 9 is part of my Novation Impulse keyboard, and I’m successfully controlling all the other faders in Nuendo using HUI. Unfortunately (only realised this after buying the keyboard) Fader 9 doesn’t get included in the HUI setup, it always transmits CC7 (or any other controller). Hence trying to find another way to get the 9th fader to always connect with the Output.

I can break it by not having VST 1-16 selected, and trying to do an ADD which appears you did by “untitled” Switch to VST 1-16 and it works again.


Yeayyy You got it! Working a treat now - thanks man!

1 Like

Ahhh… Nothing’s ever perfect, is it? Changing the number of audio tracks in the project breaks the link with the master fader - if I add a track, the fader controls the fader to the left of the master…

Create a vca track linked to master and place it in the beginning of all mixer channels, then remote that vca track instead of master. It should work no matter how many channels you will add later. Hope it helps.


Very interesting idea! Thanks, will try it

Thanks McSound, works a treat

Glad it works! :+1:

Hi, If you have the control room enabled, you can assign your midi fader to the control room output volume too…