Sub-montage, external processing and buffer bug


I posted last year about a bug happening sometimes, and I guess I found the culprit.
I made a sub-montage with pink noise, and put external processing “plug-in” in inspector. On the analog side is only a soundcard roundtrip. I also tried as render through master section and had the same effect.

Firt, try the plug-in stock

And render. It is as it should, with the roundtrip delay.

Let wavelab detect the latency

Then render. You see there is a gap, it’s exactly 256 samples here, the size of my audiocard buffer.

If manually, I try other latency, it works as it should up top a point. Exemple with 19 ms, it bugs also : audio starts at 2 ms as it should, then another 256 samples of silence.

Until last week, I did not had my previous problem in 6 months (random 256 buffers of silence inserted on rendered sub-montage through external processing) but since I insert 1sec of silence at the beginning of everyfile, I did notice that small bug but didn’t care for it as it was harmless. Now I tend to think it may be linked.

I tried with the option “reset plugins before render” both on and off and it’s the same.

edit: can’t embed pictures for now

Edit : upload is sorted now, thanks :slight_smile:

Adding to the topic, is there a way to make Wavelab stop rendering and prompt an error if it detects a drop-out ? Like Cubase does on real time rendering for example ?

I also found the old topic about the issue.

What do you mean?

Spelling mistake, I meant “linked”

It does the same issue : a buffer length filled of silence. One is everytime at the beginning of the render as on the picture. The other is random place in the render (and I didn’t have the bug occuring for 6 months, but had one last week). Both cases, Wavelab renders as if everything is OK, and searching / checking inside the files if there is a drop is very time consuming.