sudden crash when opening Score

Cubase 4.5.2, MacBook Pro 17" Duo, OS10.7.5.
I have gotten a bug - Cubase will open fine, it will open my projects, and the piano roll edit window will open fine, but when I try to open the score window, it opens then crashes. I notice that no matter what project I do this with - I have tried about 10 -, the layout of the score window (Chord symbol edit window, Score settings window, Page layout score window, all in the same location on the monitor) is the same each time. I also found a couple of my projects that I closed with the score window active, and, if I try to open that project, it will open the score window at load up, with that same layout, then it will crash. I shut Cubase all the way down, and when I open a different project, Cubase sees the previously opened project, and asks if it want to activate.
This is copied from the crash report, and there are a total of 6 threads,inc. this one.:

Application Specific Information:
objc[493]: garbage collection is OFF
Thread 0 Crashed:: Dispatch queue: com.apple.main-thread
0 com.steinberg.cubase 0x00eae7c3 0x1000 + 15390659
1 com.steinberg.cubase 0x00eb0886 0x1000 + 15399046
2 com.steinberg.cubase 0x00b32666 MpexSetProperty(long, long double, unsigned long, void
) + 90822
3 com.steinberg.cubase 0x00a40acf start + 10739371
4 com.steinberg.cubase 0x00b32565 MpexSetProperty(long, long double, unsigned long, void
) + 90565
5 com.steinberg.cubase 0x00b34b24 MpexSetProperty(long, long double, unsigned long, void*) + 100228
6 com.steinberg.cubase 0x00aa912d start + 11166985
7 com.steinberg.cubase 0x00aa92c9 start + 11167397
8 com.steinberg.cubase 0x00b562d0 MpexSetProperty(long, long double, unsigned long, void*) + 237360
9 com.steinberg.cubase 0x0088a1b5 start + 8942993
10 com.steinberg.cubase 0x007ce299 start + 8173173
11 com.steinberg.cubase 0x00002d32 start + 270
12 com.steinberg.cubase 0x00002c4d start + 41**

What can I do to fix this? I need to make some scores now, for a gig Sat night…

I would suggest disabling your prefs temporarily by changing the prefs folder’s name - not 100% certain what that was for C4, but probably:

/Users//Library/Preferences/Cubase 4/

Looking for it now… I assume it will be something like “com.cubase.pref”? Looking in the user prefs, I see a list of files labeled for instance “com.apple.Bluetooth.plist”, and I also see my prefs for Amplitube. Is that the right place? I don’t seem to find it in either user or system Prefs folder. If I knew the exact name, maybe I could do a finder search for it?

No. The Library folder is hidden by default. but if you hold down the option key when accessing the Finder’s “Go” menu it will be displayed.

Or hit command-g in the finder and paste:

~/Library/Preferences/

Then find the Cubase folder.

Thanks! Found it. My bad for trying to do this pre - coffee…Do you mean the Entire Cubase 4 folder in the preferences folder? Just checking to make sure -I have it open right now…

Can I move it to the desktop, then restart?


PS - I tried it as you suggest, renaming the folder "Cubase , 4BADbut I get a window that says “No valid license for Padshop” Retry / Cancel, then Cubase locks and stops loading, without allowing me to choose between cancel / Retry. Force quit gets me out of Cubase


PS - is the culprit the “Score Setting WIndow.xml”?

Yes, the whole folder for troubleshooting, You can just rename it, or move it, same thing.

No need to restart the computer, and Cubase should not be running while you do this.

Maybe, or something else.

You can save presets of all your prefs and Key Commands, they will be saved in the Presets folder.

We’re overlapping :slight_smile: see my new PS -------

Gotta eat - back on 20 minutes… I tried pulling out the score.xml files, but that wasn’t it. I guess I should find the “pad” files / folder and drop it into the new CUbase 4 folder (Which I moved to the desktop to test the old C4 folder minus the score.xml’s

Please stop. you are not following my directions if there was a license error.

Please don’t edit previous posts, just hit reply.

Probably you should just visit https://www.steinberg.net/en/support/knowledgebase_new/show_details/kb_show/troubleshooting-instructions-for-cubase-nuendo-and-sequel-on-mac-os-x.html

…and follow the suggestions there.

I followed your instructions exactly as you originally suggested. I renamed the folder as Cubase 4Bad, and left it in the prefs folder, and got this “pad” prompt. Apparently, your suggestion may not have taken into account the “pad” issue, hence the effort to remove particular score xml files to isolate the culprit. It looks like I will have to do a content comparison, until I can find that pad file / folder, drag it into the newly created Cubase 4 folder,and see if that solves the score window problem. But thank you for your input, and I will look at the link you sent…

Oh, I see. I know what caused that license error- the PadShop VST must have been blacklisted by cubase previously, and now Cubase is choking on it.

Those files are elsewhere, the locations are in the knowledgebase article, possibly even the same one as I linked to…

Good luck, I’m sure you’ll sort it out.

It could be something got corrupted in the folder swap. Cubase repeated the original Score issue with the original Cubase 4 folder, maybe 3 times (I was trying to narrow down the particular file, one xml at a time - I thought the creation date would give me a clue, but nogo), then, when I swapped back to the newly created Cubase 4 folder, this new issue started.

I updated and ran maintenance on the eLicenser, but that didn’t fix it.

I moved the dongle to a different usb port that I can see, and the Red LED isn’t blinking at Cubase start up, but at least I can see that its on… SO for sure, it’s not a USB port or dongle problem now. I found the padshop folder (Library>Application support>Steinberg) that contains "subpresets> CC /startup / Zone. Do you have any idea which one of these could be the problem, and if simply pulling it out of the folder will fix it? I was assuming there would be a file or folder labeled Blacklist…

According to the Article Details help, I will have to remove all of the eLicenser files and folders to try to make it run. $%^&*(!!!. Would you be able to help narrow this down a bit? This is getting scary- I’m afraid I could lose my authorizations by doing this…

I doubt there’s anything wrong with your elicenser. The error about Padshop is saying that you have Padshop installed, but you don’t have a license for it. (Padshop is included with later versions of Cubase, but not C4, as far as I know. )

Maybe you tried it out?

If you remove the Padshop VST from your system Cubase won’t look for its license, presumably.
On my system it’s at:
/Library/Audio/Plug-Ins/VST3/Steinberg/Padshop.vst3


VSTs are normally located these folders or their subfolders:

/Library/Audio/Plug-Ins/VST/
/Library/Audio/Plug-Ins/VST3/
/Users//Library/Audio/Plug-Ins/VST/

thanks. After doing those horn charts by hand, I need a break. They are going to hate my chicken scratching manuscript… Out of the frying pan, etc.

I found in /Library / Audio / VSTXMLs / Steinberg Technologies / a folder called Padshop.

In /Library / Audio / Plugins / VST3 / Steinberg, I found a component "Padshop.vst3

Nothing in the VST folder.

I went looking in /Users//Library/Audio/Plug-Ins/VST/ and found a bunch of folders, but none of them contained a padshop file or folder.

And yes you are right, but it was Cubase LE5 I tried out. And way back, I tried C7, but removed it. And I found a couple of C7 folders floating around. I think you nailed it. I assumed that C LE5 would not mess with C4 - my bad… Now just to make sure I do not muck up anything, should I remove both the Padshop folder and the padshop component file? Should I remove C LE5 altogether?

You are trying to do so much, and only one thing is needed to stop Cubase from looking for the Padshop license.

Remove: /Library/Audio/Plug-Ins/VST3/Steinberg/Padshop.vst3

Then, you can go back to doing this: http://www.steinberg.net/forums/viewtopic.php?f=146&t=58936&view=unread#p355846

Thanks again. So just the component then, not the folder. The less I molest Cubase and Padshop, to get it to open Score without crashing, the better… I’ll get back to this tomorrow- gotta go play and see how the charts work…

Wheee! I removed the Padshop component, then Cubase 4 stopped loading at Retrolog, so I removed that, and now it stops at VST bridge.

Where is VST bridge? Is there anything else that is going to jump up in my face? To quote Bill the Cat – Ack.

R

Annnnd it works! The VST bridge prompt was a one time thing. Score works correctly and so far, knock on wood, C4 is working as it should.
Thanks again for your help with this.