Suddenly The licensing stopped working

Opened Cubase for the first time today and

Screenshot 2022-03-18 153509

So I tried to check the manager and it is stuck on this

Rebooted the computer. Same thing. Tried the Studio computer. same.
It’s like the licensing system suddenly booted me off, or sent out a disable to my machines.

1 Like

I opened download manager.
It updated the eLicenser.
Still no go.
Rebooted to no avail.
Rebooted again… now it works again.
Very strange indeed.

This is my worst fear for the new Steinberg licensing system. I had a Roland Cloud subscription and the server kept refusing to connect. I got so frustrated that I finally cancelled my subscription. I hope the new Steinberg licensing system isn’t the same.

Well this new licensing system isn’t supposed to need the internet once its already installed and activated so this is rather odd…

1 Like

It is odd, the only thing I can think of was that it was the internet connection that was the issue. I was just asked if the internet was down for me too. It seems there was no connection for about 30 minutes, and it came back just as Cubase started working again.