Super slow MIDI Initialization

This is driving me crazy… I just pinged Steinberg support with this, so rather than re-write the whole thing, I’ll paste it here:

I just bought an SSD to speed up Cubase load times. It s been really, really good for that! But, all of a sudden, as I m installing plugins, the MIDI initialization phase on startup is grindingly slow. It s so slow it defeats the whole purpose of having spent $675 on a high end SSD. Load time is now completely unacceptable, slower than when I had it on the regular HDD!

It wasn t like this before; I had a good 2/3 of my pretty substantial plugin collection installed, and everything was great. Today, I m probably over 3/4 of the way there, and suddenly this starts happening.

Why is it doing this? Any help would be much appreciated…

Thanks,

DrW

\

So, anyone have anything like this happen recently? I hope Steinberg has something to say about it, but if any of you all know anything, please let me know! I’d really, truly appreciate any help on this… losing my mind over here uninstalling and reinstalling and de-activating devices/ports… please stop me before I do something stupid out of frustration! :laughing:

OK, nevermind, I FOUND IT! :smiley: :ugeek: :smiley:

I had just put new video cards in my system (a pair of GeForce GTX 570s), and installed the drivers. Well, I go into Device Manager and decide to delete all other devices except for my RME interface. Sure enough, there are like 8 "NVIDIA high definition audio device"s listed! I uninstall them all, plus “USB Audio Device” (I have no idea what that is or how it got there), plus my built in mobo HD Audio device, and voila!

SUPER fast Cubase start times! Oh, I am SO chuffed right now! :mrgreen:

FOLLOW UP

(This could be important to anyone using recent NVIDIA cards!)

OK, so after restarting, I got the same thing… WHAT?!? Crap… same thing. Every time I’d try and uninstall these audio devices, they’d reinstall themselves upon restart, and I’d be back to square one. Disabling them helped, but not much. Cubase would still try to mess with these virtual devices, but not for as long as it would when they were enabled.

After a couple hours of pacing and surfing and more pacing, I finally found something useful:

http://www.evga.com/forums/tm.aspx?m=586183&mpage=1

This is the method to permanently disable the NVIDIA cards’ “High Definition Audio” as a system device. It works! Cubase opens very, very rapidly now on my SSD.

Steinberg, please get on top of this! This was causing Cubase to take about 7-10 times as long as it normally should to open! By following the procedure in that EVGA forum thread above, you can force your system to ignore your NVIDIA cards HDMI audio properties completely and just load Cubase without trying to check these virtual audio devices. Brilliant! :sunglasses:

The problem is that Steinberg can’t control this. It’s a physical audio card.

These aren’t “virtual” audio devices. They’re actual audio outputs (through the card’s HDMI).
Can be solved by not installing the HD audio driver when you install your NVIDIA card, and then not installing the driver with each update.

Your solution wouldn’t work, I’m afraid, as unless the relevant PCI buses are disabled under “System” in device manager, you can uninstall them, restart, and they’ll be right back. If you install the audio ‘option’ while installing the video card drivers (I don’t recall that the wizard mentioned anything about that at all!), which I believe is default, the devices will show up as “NVIDIA High Definition Audio Device”. Nine of them. Uninstall one, and they all will uninstall.

Now, if you do so and restart, they’ll come right back, but a generic driver will install instead of the NVIDIA driver. They’ll show up in Device Manager as “High Definition Audio Device”. Even if you disable them, Cubase will take a long time to launch, but not as long as if they’re enabled. If you uninstall them, you’ll have to do them one by one.

So, in order to completely remove them from Cubase’s sight and keep them from coming back, you must follow the method outlined in the link above.

I spent far too long on this, trying various things… this is the only thing that worked!

So, again, I really urge Steinberg to look into this. If REAPER can open in a flash, I don’t think it’s too much to expect that at the very least Cubase should be smart enough to know what audio devices and MIDI ports to ignore completely upon boot.

That is all…

My solution simply wasn’t to install the drivers in the first place.

They won’t be there if you don’t install them. Windows tends to leave video cards and video card related drivers (especially the higher end AMD and NVIDIA cards) out of its inbulit driverbase (since they change so ofter). When you install these drivers (even one time) they’re in windows driverbase forever, hence re-installing on reboot.

I’m running a NVIDIA GTS 240 in this system. Never installed the HD audio drivers (or the 3D vision drivers either). They don’t show up in my device manager. Ran Cubase Elements trial on this computer. Started fine.

Yes, it is. However, there is a “custom” setup option.

Cubase says: “I’ll ignore these!”
User says: “But I wanted to use those…”

Could potentially cause more frustration than good.

And what’s to say that it wasn’t simply an IRQ conflict?

Hello,

I have a ATI Radeon HD 5750 and i have the same problem. (win7, i7 980x, cubase 6.5, ATI radeon hd 5750, 12go ram, fireface 800…).
I change my hard disk 7200tr for a crucial SSD M4 128Go but cubase Spend a long time to initialize midi!! :blush:
I have uninstall ATI HDMI AUDIO but without any success…

I hope Steinberg Will fix this issue as soon as possible!!!

If you have a solution, thank’s to help me.

Best regard
French Davvv (Sorry for my english)

Plus one here!!!

I know the initialization time is dependent on the number of audio device drivers, but there must be a way to speed up the interrogation of them, or to cache their properties, or to allow us to select the audio device driver we want to use in Cubase settings and only scan that one on startup.

I would happily sacrifice the capability to hot switch audio drivers for a faster startup.

I use one driver for Windows system output through one interface and one driver for output from Cubase with a completely different driver and interface, but I always use just this one driver with Cubase.

Does anyone really need to hot switch drivers? And if they do, can it not be a check box option: “Lock Audio Driver on next startup”, so that we can choose whether it’s fixed or flexible.

Pleeeeeeeeeease Steinberg - implement this! This is driving me nuts! And wasting sooooooooooooooooooooooooo much time.

G

http://support.microsoft.com/kb/241257

Updated link:
http://forums.evga.com/PROCEEDURE-to-PERMANENTLY-DISABLE-THE-NVIDIA-HD-sound-deviceBLACK-SCREEN-LOGIN-FIX-m586183.aspx