superior drummer 3 not showing up

I searched to no avail. New computer, new hard drive, etc. Installed Cubase 10, Halion Sonic 3 (actually bought it to use with PTools - that’s another subject), and Superior drummer. Halion shows up fine in the VST instruments but superior drummer is nowhere to be found.

Superior drummer works stand alone. I must have done/not done something during installation.

I know this has been answered probably dozens of times but if anyone knows the quick and dirty fix, I’d sure appreciate it.

You did not list your computer OS… Please do… :wink:
If Windows…
If you looked in each VST folder and it truly is not listed anywhere then look at this topic. Fabio lists were the different VSTs should be installed on a Windows OS.

Regards. :sunglasses:

Thanks for the reply, I figured it out. Win 10 BTW

I went to the stand alone of Superior Drummer and under the help tab there’s an option to have it show you the path to the vst. in my case C:\Program Files\Common Files\VST3\Toontrack

Once armed with that information, adding that path to Studio>VST Plug in Manager was pretty straightforward. The joys of setting up a new computer.

Thank you again for the reply.

Thanks for the tipp. I had the same problem and I solved it with your description.

Thank You for sharing this! I recently had to reset my Cubase 10.5 and had totally forgotten about how to do this. Just for the h*ll of it I added C:\Program Files\Common Files\VST3 in the plug in manager and not only got my Toontrack instruments back but also a plug in! :slight_smile:

Thank You!

Here’s another one crreeping out of the woodwork hehe.

I just happened to be dealing with that folder yesterday for EZ Drummer. I keep a c:\vst folder for various plugins to keep things from being scattered all over the place, but was getting weird error messages about EZ being out of date. Turns out I’d updated EZ but C:\Program Files\Common Files\VST3\Toontrack wasn’t in plug in manager, and it was still picking up the old dll, which I’d forgotten to remove. So, cockpit error in a number of places.

No, I didn’t say “rock” error. It was c0ckpit error, but apparently the filter isn’t smart enough to realize I didn’t say a naughty word.