Support non existent?

Ok, reinstalled Wavelab, immediately hung when opening, but didn’t completely crash the PC. Log Name: Application
Source: Application Hang
Date: 15/05/2024 12:29:06
Event ID: 1002
Task Category: Hanging Events
Level: Error
Keywords:
User: SYSTEM
Computer: DESKTOP-061SAIA
Description:
The program WaveLabPro12.exe version 12.0.20.611 stopped interacting with Windows and was closed. To see if more information about the problem is available, check the problem history in the Security and Maintenance control panel.

Event Xml:



1002
0
2
101
0
0x8000000000000000

26258


Application
DESKTOP-061SAIA



WaveLabPro12.exe
12.0.20.611
0x4a90
0x1daa6baf797b60c
66
C:\Program Files\Steinberg\WaveLab Pro 12\WaveLabPro12.exe
9a2702ac-52ff-4aef-8e4c-2dc2517c3e84




Unknown

1 Like

I’ve been using Wavelab almost daily for about 20 years. I have TONS of plugins and have never had a problem. The only problem I’ve ever had with it is when they did something that made it so jBridge no longer worked with it, but they ended up fixing it in an update. No complaints here and I’d say the problem is the plugin and not WL.

BTW…PG1, who has been responding to your comments, is the developer of Wavelab. You can’t get anymore personal attention from Steinberg than that. :wink:

4 Likes

This is just a snapshot from the Windows Event Viewer and tells basically nothing. It just says the process is hanging, but no reason why.

If you are really interested in getting an idea of where it hangs you should use Procdump from Microsoft SysInternals, to get a dump file.

Please download ProcDump64 from Microsoft (~710kB) and extract the archive to a local folder on your hard disk. Ideally create a folder procdump in your Downloads folder.

Run Command Prompt (cmd) as administrator (right click and select “run as administrator”)

Navigate (in the Command Prompt) to the folder with the extracted procdump file.
For example:
cd C:\ Users \<your user>\ Downloads \ procdump
Note: the dmp file will be written into that folder.

Launch Wavelab. You can work as usual. At any time, like when it starts hanging, change to the command prompt and start procdump, to monitor Wavelab for unexpected behavior (see next step).

Launch procdump64 via Command Prompt:
procdump64.exe -e -h -t WaveLabPro12.exe

When you close WaveLab, because it hangs, a dump file will be written here and that has more information on what is really happening.

1 Like

PG I think you are the best when it comes to WL. I respect your judgement and knowledge. BUT If a plugin works in all my other DAWs and does not work in WL then it is safe to assume that WL is doing something different that causes the plugins not to work in WL. What is it that is different in WL that causes plugins not to work and yet they work in all other DAWs? It must be something that WL does differently than all the other DAWs. I could see your point if the plugins work in only 50% of all the other DAWs but the plugins work in ALL the other DAWs I have just not in WL. Something is amiss and it seems as if Steinberg, not you, does not want to admit there is a problem. This has been going on for years so it is not a NEW problem. Thanks for your understanding and hopefully this can be “fixed” some time in the future.

1 Like

Ok, thanks. Saying the file is too big to attatch here

This is a common misunderstanding. No, it’s not safe to assume that at all.

1 Like

Try to use Dropbox or Wetransfer and share a link to it.

I am not a programmer and the last time I worked on authoring software was in college. BUT if a plugin works on all the other DAWs and does not work on WL then there is something that WL is not doing or doing that is preventing the plugin from working. There must be a protocol that is not being followed or something in the coding of WL that prevents certain plugins from working correctly. Yes the plugin authors should be checking their plugins with WL but also WL needs to look at their programming to see if it is having problem with certain plugin due to (fill in the blank).

If I author a CD and it plays on every CD player in the world EXCEPT one brand then it cannot be my authoring…it has to be something in the CD player…Is that so hard to understand. Again if it played in only 50% of the players then it might be my fault in the authoring. If only one manufacturer’s CD player will not play it then it is NOT my fault but the manufacturer’s problem…Why is that so hard to see???

1 Like

Once again, this is a common misunderstanding and one that you keep repeating here. Wavelab is not ‘doing’ or not ‘not doing’ anything to cause the plugin not to work. For the sake of clarity, I refer you to the following:

And so I’d ask you the same question you are asking of others here… why is this so hard for you to see?

I’d also suggest that your attempts to apportion some kind of responsibility for plugin issues into Wavelab’s camp, when really this is unfounded, is counter-productive. While I understand your frustrations with various plugins, in my humble opinion this line of argument is no longer serving any real purpose here. Just my two cents.

4 Likes

I will get off my “soapbox” for the present but I still think there is something that WL needs to investigate. Maybe someone else from outside the WL camp should look at the problem since it seems to be a long standing one.

I don’t know who you are or if you are speaking a a Steinberg employee or just an interested onlooker. FWIW

1 Like

Couldn’t post on here for 18 hours. Why? Who cares? Dmp files are unsupported by dropbox. Thanks for all the replies folks, I appreciate it, but I’ll just put this down to experience and stick with Studio One. Finished with Steinberg.

Make it a ZIP File and you can upload it.

Hi!

You should know by now this is not the official support from Steinberg here…
even if PG and user expertis is here at this forum check out this …
https://helpcenter.steinberg.de/hc/en-us

regards S-EH

I know. There is no Steinberg official support. That’s why I came here.

Zip file is still miles too big.

For Dropbox?

Sorry, Juergen, my bad, I misunderstood.

Just checked this link and I don’t think it’s letting me share on Dropbox. Let me know if it can be accessed

No problem, I was able to download the file and the dump shows that you are having a problem with the REFERENCE plugin

image

The plugin seems to hang and wait for some event in Windows. You can try to move the plugin out of the way so it is not being loaded anymore and see if that helps. Of course you can also try to uninstall it, but I would first try to move it somewhere else.

2 Likes

Ok, thanks Juergen, the issue has been when I try to unload reference from the master section it was crashing my whole system. Moving the file has allowed me to open WL again without issue.