Sustain Pedal In Note Entry

Running Dorico 5.1.21.2098 on Windows 11
Edit, please see the 4th post in this thread as I misidentified the problem in my first post.

I’m using pitch-first note entry. Currently not only are the notes from my MIDI keyboard entered when I press the length key (5, 6, 7, etc.), but also any notes held by the sustain pedal are also entered. I can see the usefulness of this at times or to some. Unfortunately, it’s not useful to me or my workflow.

Is there a preference to turn this off so that only the notes currently being pressed on my MIDI keyboard are entered, and not notes held by the sustain pedal as well?

I’ve searched help, this forum, and Google, and none of my keywords have turned up the answer I need.

Thanks! :slight_smile:

the sustain pedal basically stops the software from “seeing” a “note off” instruction… until the sustain pedal itself is turned off.

remember, MIDI is at its simplest nothing more than note on / note off information.

the best thing to do would be to avoid using the sustain pedal of your keyboard when entering notes.

1 Like

Thanks for the comment @Michel_Edward. This is a common belief about MIDI, but it’s actually not the case. The sustain pedal is simply another MIDI controller (#64) that provides a value as to what position the sustain pedal is in. The MIDI keyboard sends note on and off exactly the same, regardless of whether the sustain pedal is pressed or not.

This feature in Dorico took some effort to implement, and I think it’s great. Finale can’t do this, and only transcribes the notes that are still on when the length key is pressed.

I can see the usefulness of this feature, for example entering chords that you can’t reach with one hand, sustaining them, and then hitting the length key. It just doesn’t work for my workflow presently and I’m looking for a preference to turn it off.

Try unticking this preference. (In the main Dorico Preferences dialog, which is on the Dorico menu on Mac and - I think - the Edit menu or Library menu on Windows)

1 Like

How curious! It appears there is something different going on here than I thought: I mistook the issue to be related to the sustain pedal. But apparently, it’s something else with the way pitch-first entry works. It seems the sustain pedal is a red herring and has no effect on note entry.

  1. If I play a chord on my MIDI keyboard by playing all three notes simultaneously, and then hit the length key all three notes are written as expected.

  2. If I roll it quickly, still holding (or not) all three notes, when I hit the length key all three notes are written.

  3. If I roll the chord slowly, even if I am still holding all three notes when I hit the length key, it only writes the top note.

  4. If I play 6 notes, and release 3, all 6 get entered anyway–with or without the sustain pedal held.

So I guess what I’m actually looking for is a preference for pitch-first entry where only the notes currently held (on) on my midi keyboard at the moment the length key is pressed are written, ignoring any previously played notes, regardless of how quickly/slowly the currently held notes were played. Only–and all–notes currently “on” when the length key is pressed get written.