Sustain Pedal Issue (Help ?)

Hi folks,

i have been stuck on something all week and i am not at all sure why this is happening. So would be fantastic if someone could explain this issue to me please.

i have my control keyboard (Nord Stage 88) midi into my PC to trigger sounds within HALion Sonic. i choose a sound (say Strings) and play sustained chords holding these down with the sustain pedal. No problem.

Now, when i press RECORD (to obviously record what i am playing) the sustain pedal does not work anymore ?? And when i stop recording it works again perfectly !! ?? In other words, i will not activate during Record Mode.

i really can’t solve this one so any help would be greatly appreciated.



And exactly the same thing happens with the MODULATION WHEEL. Though the PITCH BEND works fine in both situations !! ??

Preferences>MIDI>MIDI filter
There are a bunch of boxes to check. Maybe that’s it?

Thank you. It sorted out the problem !!

What i would like to know also please is regarding Midi Volume. Is it possible to have Cubase receive the likes of Pitch Bend, Mod Wheel, Sustain etc, but NOT receive VOLUME CHANGE ?? i think all the afforementioned are bundled within ‘Contollers’ so what i am asking here is - is there a way to manipulate the on/off setting for Volume Change ??

yes. In the same Midi filter window, in the “controller” section, you can select any MIDI controller. Volume is always CC 7.
Or just don’t record any CC7 data by not using the assigned controller while you are recording?
Screen Shot 2013-02-18 at 12.55.15 PM.png

Thats superb man, thanks a lot.

In the RECORD column there is a box called PROGRAM/PATCH. i am a bit confused as to whether or not this is the same as PROGRAM CHANGE ??


I think it basically is the same. The manual describes this on p. 350 and pp. 103-105.
I see you have a lot of hardware instruments. I think the patches are for when you set up your Nord (for example) as a “device”

i am looking to use the Nord as a controler to trigger the sounds in HALion Sonic.

And also to be recorded as Audio using the Nord piano and organ samples etc. These keyboard type samples on the Nord are better than the ones in HALion (plus i have programed them how i want them to be).

In any case, do i need to set anything in Devices if i was to alway use the Nord as a Device ??

I feel the same way about my Kurzweil.
You need to set this up in DEVICES > MIDI DEVICE MANAGER.
Install device. If your Nord is on the list, great. All your patch names will now appear in the track inspector. Pick your sound and go. If it’s not (like mine) you have to find a patch script - a text file of all the sounds - or create one. I located one through the Kurzweil forum. Nord must have the same type of support. The file has to be put in the correct folder in your computer. ( that was the hardest thing for me to learn)
It took a bit of fiddling around, but it’s totally worth it to make working with your Nord much easier.

***if you created NEW sounds, I think those have to entered manually by you.

i set everything as in your screenshot (thank you) but the Volume Messages are still getting thru ?? Yes you are correct in suggesting i avoid sending any Volume Changes over midi whilst recording. But the problem is that everytime i change preset on the Nord (say from 001 Piano to 002 Organ) the Volume Sliders in Cubase are thrown into confusion.

Hope you can help as i have spent over a week on trying to solve this !! :confused:

I never played the nord, but I took a moment and downloaded the manual. Chapter 10 & 11 explain the EXTERN mode. Look at pages 64 and 70. That keyboard has the ability to send a volume command out over MIDI for each program. You want to disable that function.

Cheers, i actually tried this earlier and it does work. If you set the External Section Midi Volume to OFF (so not 000 to 127) and save the preset, the sliders in Cubase are not effected when you call up the preset. Therefore i am guessing that because i have all of my presets stored with the External Section Midi Volume at 127, i am now going to go thru all the presets and resave them with this parameter turned OFF. A pain in the arse but i can’t see any other way around it. i would have thought that by disabling everything (as we did) within Cubase it would have just simply ignored any incoming Volume Change messages from the Nord, but this is obviously not the case ??

The only thing to watch is that (because the Nord is very interactive and favours lots of live knob twiddling !!) if you accidentally catch the External Section dial it will reset all the Cubase sliders.

Do you think this is the only way around this issue as we have tried everything i can think of !! ??

I really can’t say - I don’t know the keyboard. If it’s not making sense to you and you’ve looked at the manual, I would definitely try the Nord forum. I’ll bet this is a common issue.

Will do, thanks very much indeed.

The are a couple of Nord Synths in the Devices, but not the Nord Stage Classic. Though i have totally changed all the presets (and their locations) from the shipped factory sounds.